您的位置:首页 > 其它

hdu 1535 Invitation Cards

2014-02-12 14:42 211 查看

Invitation Cards

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1626 Accepted Submission(s): 729


[align=left]Problem Description[/align]
In
the age of television, not many people attend theater performances.
Antique Comedians of Malidinesia are aware of this fact. They want to
propagate theater and, most of all, Antique Comedies. They have printed
invitation cards with all the necessary information and with the
programme. A lot of students were hired to distribute these invitations
among the people. Each student volunteer has assigned exactly one bus
stop and he or she stays there the whole day and gives invitation to
people travelling by bus. A special course was taken where students
learned how to influence people and what is the difference between
influencing and robbery.
The transport system is very special: all
lines are unidirectional and connect exactly two stops. Buses leave the
originating stop with passangers each half an hour. After reaching the
destination stop they return empty to the originating stop, where they
wait until the next full half an hour, e.g. X:00 or X:30, where 'X'
denotes the hour. The fee for transport between two stops is given by
special tables and is payable on the spot. The lines are planned in such
a way, that each round trip (i.e. a journey starting and finishing at
the same stop) passes through a Central Checkpoint Stop (CCS) where each
passenger has to pass a thorough check including body scan.

All
the ACM student members leave the CCS each morning. Each volunteer is
to move to one predetermined stop to invite passengers. There are as
many volunteers as stops. At the end of the day, all students travel
back to CCS. You are to write a computer program that helps ACM to
minimize the amount of money to pay every day for the transport of their
employees.

[align=left]Input[/align]
The
input consists of N cases. The first line of the input contains only
positive integer N. Then follow the cases. Each case begins with a line
containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is
the number of stops including CCS and Q the number of bus lines. Then
there are Q lines, each describing one bus line. Each of the lines
contains exactly three numbers - the originating stop, the destination
stop and the price. The CCS is designated by number 1. Prices are
positive integers the sum of which is smaller than 1000000000. You can
also assume it is always possible to get from any stop to any other
stop.

[align=left]Output[/align]
For
each case, print one line containing the minimum amount of money to be
paid each day by ACM for the travel costs of its volunteers.

[align=left]Sample Input[/align]

2
2 2

1 2 13
2 1 33
4 6
1 2 10

2 1 60
1 3 20

3 4 10
2 4 5

4 1 50

[align=left]Sample Output[/align]

46

210
第一次正向spfa 可求1 到其他点最少的花费
第二次反向()spfa 可求其他点到 1 的最少花费

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
#include<set>
using namespace std;
#define inf 1000000000+10
struct node
{
int to;
int w;
};
int n;
vector<node>p[1000100];
vector<node>q[1000100];
int cost[1000100],vit[1000100];
int spfa(int pos,vector<node>s[])
{
int i,j;
queue<int >lp;
memset(vit,0,sizeof(vit));
for(i=2;i<=n;i++)
cost[i]=inf;
cost[pos]=0;
lp.push(pos);
while(!lp.empty())
{
int t=lp.front();
lp.pop();
for(i=0;i<s[t].size();i++)
{
int a=s[t][i].to;
int b=s[t][i].w;
if(cost[a]>cost[t]+b)
{
cost[a]=cost[t]+b;
if(!vit[a])
{
lp.push(a);
vit[a]=1;
}

}
}
vit[t]=0;
}
int sum=0;
for(i=2;i<=n;i++)
sum+=cost[i];
return sum;
}
int main()
{
int time,m,sum,i;
cin>>time;
while(time--)
{
sum=0;
cin>>n>>m;
for(i=1;i<=n;i++)
{
p[i].clear();
q[i].clear();
}
for(i=1;i<=m;i++)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
node d,e;
d.to=b,d.w=c;
e.to=a,e.w=c;
p[a].push_back(d);
q[b].push_back(e);
}
sum+=spfa(1,p);
sum+=spfa(1,q);
cout<<sum<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: