您的位置:首页 > 其它

kmp简单应用

2014-02-11 18:57 351 查看

Power Strings

Time Limit: 1000MS Memory limit: 65536K

题目描述

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation
by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).



输入

 Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A
line containing a period follows the last test case.

输出

 For each s you should print the largest n such that s = a^n for some string a.

示例输入

abcd
aaaa
ababab
.


示例输出

1
4
3


提示

 This problem has huge input, use scanf instead of cin to avoid time limit exceed.

来源

 题目的意思看起来麻烦,但是就是求最大连续字串。

示例程序

#include<stdio.h>
#include<string.h>
int main()
{
int len,i,j,ok;
char a[10000001];
while(gets(a))
{
if(strcmp(a,".")==0)break;
int len=strlen(a);
for(int i=1;i<=len;i++)
if(len%i==0)
{
int ok=1;
for(int j=i;j<len;j++)
if(a[j]!=a[j%i])
{
ok=0;
break;
}
if(ok)
{
printf("%d\n",len/i);
break;
}
}

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c acm