您的位置:首页 > 运维架构

Diophantus of Alexandria

2014-02-10 22:42 197 查看


Diophantus of Alexandria

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2139 Accepted Submission(s): 808



Problem Description

Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are commonly called diophantine equations.
One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat's last theorem) was found only recently by Andrew Wiles.

Consider the following diophantine equation:

1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)

Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions:

1 / 5 + 1 / 20 = 1 / 4

1 / 6 + 1 / 12 = 1 / 4

1 / 8 + 1 / 8 = 1 / 4

Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly?

Input

The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9).

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given value of n. Terminate each scenario
with a blank line.

Sample Input

2
4
1260


Sample Output

Scenario #1:
3

Scenario #2:
113


Source

TUD Programming Contest 2006

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define M 40000
int  prime[50100];
void table()
{
int i,j;
memset(prime,0,sizeof(prime));
for(i=2; i<=M; i++)
{
//printf("aaa\n");
if(prime[i]==0)
{
//printf("bbbb\n");
for(j=i+i; j<=M; j+=i)
{
prime[j]=1;
// printf("ccc\n");
}

}
}
}

int main()
{

table();
int n,i,j,k,t;
scanf("%d",&t);
int sum;
int e=1;
while(t--)
{
sum=1;
//printf("aaa\n");
scanf("%d",&n);
for(i=2; i<=M; i++)
{
if(n==1)
break;
if(prime[i]==0)
{
k=0;
while(n%i==0)
{
k++;
n=n/i;
}
sum=sum*(2*k+1);
}
}

if(n>1)
sum=sum*3;
printf("Scenario #%d:\n",e);
printf("%d\n\n",(sum+1)/2);
e++;

}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: