您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表四:有序链表的归并

2014-02-10 18:59 363 查看

数据结构实验之链表四:有序链表的归并


Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

输入

第一行输入M与N的值;

第二行依次输入M个有序的整数;

第三行依次输入N个有序的整数。

输出

输出合并后的单链表所包含的M+N个有序的整数。

示例输入

6 5
1 23 26 45 66 99
14 21 28 50 100


示例输出

1 14 21 23 26 28 45 50 66 99 100

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
int main()
{
    int i,n,m;
    struct node *head1,*head2,*tail,*p1,*p2;
    head1=(struct node*)malloc(sizeof(struct node));
    head2=(struct node*)malloc(sizeof(struct node));
    tail=head1;
    scanf("%d%d",&m,&n);
    for(i=0;i<m;i++)
    {
        p1=(struct node*)malloc(sizeof(struct node));
        p1->next=NULL;
        scanf("%d",&p1->data);
        tail->next=p1;
        tail=p1;
    }
    tail=head2;
    for(i=0;i<n;i++)
    {
        p2=(struct node*)malloc(sizeof(struct node));
        p2->next=NULL;
        scanf("%d",&p2->data);
        tail->next=p2;
        tail=p2;
    }
    p1=head1->next;
    p2=head2->next;
    tail=head1;
    free(head2);
    while(p1&&p2)
    {
        if(p1->data<p2->data)
        {
            tail->next=p1;
            tail=p1;
            p1=p1->next;
        }
        else
        {
            tail->next=p2;
            tail=p2;
            p2=p2->next;
        }
    }
    if(p1)
        tail->next=p1;
    else tail->next=p2;
    p1=head1->next;
    while(p1)
    {
        if(p1->next!=NULL)
            printf("%d ",p1->data);
a0aa
        else printf("%d\n",p1->data);
        p1=p1->next;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: