您的位置:首页 > 其它

Pat(Advanced Level)Practice--1008(Elevator)

2014-02-10 15:07 281 查看

Pat1008代码

题目描述:

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to
move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.
Sample Input:
3 2 3 1

Sample Output:
41


AC代码:
#include<cstdio>
#include<vector>
#include<algorithm>

using namespace std;

int main(int argc,char *argv[])
{
int k,n;
int temp,ans;
vector<int> v;
scanf("%d",&n);
for(k=0;k<n;k++)
{
scanf("%d",&temp);
v.push_back(temp);
}
vector<int>::iterator i=v.begin();
temp=ans=0;
for(;i<v.end();i++)
{
if(*i>temp)
{
ans=ans+(*i-temp)*6;
ans=ans+5;
}
else
{
ans=ans+(temp-*i)*4;
ans=ans+5;
}
temp=*i;
}

printf("%d\n",ans);
return 0;
}


注意:有几个case可能是连续停留在一层若干时间即5 2 3 3 3 1,这样只需加上每次的停留时间即可,坑啊。。。
还有一个更简单的解法:
#include<cstdio>

int main()
{
int time=0;
int now=0,n,i,m;

//freopen("input.in","r",stdin);
//freopen("output.in","w",stdout);
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&m);
if(m>now)
{
time+=(m-now)*6+5;
}
else
{
time+=(now-m)*4+5;
}
now=m;
}
printf("%d",time);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Advance Pat 基础题