您的位置:首页 > 其它

poj3259 Wormholes(spfa)

2014-02-09 20:26 267 查看
就是给出一些点边关系, 有虫洞的就是负值。 注意普通道路是双向边。。一开始这里建错图了

之后处理用了spfa ,类似模板的一道题

题目:

Wormholes

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 26848Accepted: 9669
Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W

Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.

Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle
1->2->3->1, arriving back at his starting location 1 second
before he leaves. He could start from anywhere on the cycle to
accomplish this.
Source

USACO 2006 December Gold

代码:

#include <iostream>
#include <vector>
#include <cstring>
#include <queue>
#include <cstdio>
using namespace std;
#define LEN  500+10
#define INF 10000*501
#define MP(x,y) make_pair(x,y)
typedef pair<int,int> pii;

vector<pii> G[LEN];
int N,M,W;
int dis[LEN];
void init()
{
cin>>N>>M>>W;
for(int i=1;i<=N;i++)
G[i].clear();

int s,e,t;
for(int i=0;i<M;i++)
{
cin>>s>>e>>t;
G[s].push_back( MP(e,t));
G[e].push_back( MP(s,t));
}
for(int i=0;i<W;i++)
{
cin>>s>>e>>t;
G[s].push_back( MP(e,-t));
}
}

bool spfa(int s)
{
queue<int> q;
int vis[LEN] = {0}, cnt[LEN] ={0};
for(int i=1;i<=N;i++)dis[i] = INF;

dis[s]=0;
q.push(s);
vis[s] = 1;
cnt[s]++;

while(!q.empty())
{
int v = q.front(); q.pop();
for(int i=0;i<G[v].size();i++)
{
int  x = G[v][i].first , d = G[v][i].second;

if( dis[x] > dis[v]+ d)
{
dis[x] = dis[v]+d;
if(!vis[x])
{
q.push(x);
vis[x] = 1;
cnt[x] ++;
if( cnt[x]>N-1)return true;
}
}
}
vis[v]= 0;
}
return false;
}
int main()
{
int F;
cin>>F;
while(F--)
{
init();

if( spfa(1) || dis[1]<0)
cout<<"YES"<<endl;
else
cout<<"NO"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: