您的位置:首页 > 产品设计 > UI/UE

1051. Pop Sequence (25)

2014-02-08 17:59 393 查看
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can
obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow,
each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO


思路:考察栈的应用,输入是有序的!!

参考代码:

#include <iostream>
#include <stack>
using namespace std;
stack<int> s;
int M,N,K;
int main(){
cin>>M>>N>>K;
for(int i=0;i<K;i++){
while(!s.empty()){
s.pop();
}
int isRight = 1;
int countL = 0;
for(int j=0;j<N;j++){
int input;
cin>>input;
while(countL<input){
if(s.size()>M-1){
isRight = 0;
break;
}
s.push(countL++);
}
int topV = s.top()+1;
if(topV==input){
s.pop();
}else{
isRight = 0;
}
}
if(isRight==1){
cout<<"YES"<<endl;
}
if(isRight==0){
cout<<"NO"<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: