您的位置:首页 > 其它

HDU 1193 Non-negative Partial Sums / 单调队列

2014-02-08 13:55 435 查看

Non-negative Partial Sums

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)



Problem Description
You are given a sequence of n numbers a0,..., an-1. A cyclic shift by k positions (0<=k<=n-1) results in the following sequence: ak
ak+1,..., an-1, a0, a1,..., ak-1.
How many of the n cyclic shifts satisfy the condition that the sum of the fi rst i numbers is greater than or equal to zero for all i with 1<=i<=n?



Input
Each test case consists of two lines. The fi rst contains the number n (1<=n<=106), the number of integers in the sequence. The second contains n integers a0,...,
an-1 (-1000<=ai<=1000) representing the sequence of numbers. The input will finish with a line containing 0.



Output
For each test case, print one line with the number of cyclic shifts of the given sequence which satisfy the condition stated above.



Sample Input
3
2 2 1
3
-1 1 1
1
-1
0




Sample Output
3
2
0




给你一个n项的序列,每次可以把序列的首项移动到末尾,求有多少种序列的前i项和都大于等于0

首先将序列1-n扩大一倍 拿它自己拼接到后面
转换为前缀和 要求和大于0 可以用单调队列维护一个最小值 最小值大于0 说明的都是大于0

求每一段的前缀和和 比如x-y 那么可以sum(y)-sum(x-1) 开始预处理好

只不过把原本序列变成了前缀和

#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1000010;
int a[maxn*2];
int q[maxn*2];
int main()
{
    int n;
    while(scanf("%d", &n) && n)
    {
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
            a[i+n] = a[i];
        }
        int cnt = 0;
        for(int i = 1; i <= 2*n; i++)
            a[i] += a[i-1];
        int front = 0, rear = -1;
        
        for(int i = 1; i < 2*n; i++)
        {
            while(front <= rear && i - q[front] >= n)
                front++;   
            while(front <= rear && a[i] <= a[q[rear]])
                rear--;
            q[++rear] = i;
            if(i >= n && a[q[front]] - a[i-n] >= 0)
                cnt++;
        }
        printf("%d\n", cnt);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: