您的位置:首页 > 其它

Leftmost Digit

2014-02-08 12:13 176 查看


Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11717 Accepted Submission(s): 4475



Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the leftmost digit of N^N.

Sample Input

2
3
4


Sample Output

2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.


Author

Ignatius.L

Recommend

We have carefully selected several similar problems for you: 1066 1788 3826 1568 1452

#include<iostream>
#include<cstdio>
#include<math.h>
using namespace std;
int vis(double n)
{
double integer;
double decimal=modf(n*log10(n),&integer);
double p=pow((double)10,decimal);
modf(p,&integer);
return (int)integer;

}
int main()
{
int n,c;
scanf("%d",&c);
while(c--)
{
scanf("%d",&n);
printf("%d\n",vis((double)n));
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: