您的位置:首页 > 其它

HDU1009 FatMouse' Trade

2014-02-08 00:09 429 查看
Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All
integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1


Sample Output

13.333
31.500


贪心算法:
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
#include <queue>

struct Food{
int J;
int F;
}food[1005];

int cmp(const void *a,const void *b){
Food *f1=(Food *)a;
Food *f2=(Food *)b;
return f1->F*f2->J-f1->J*f2->F;
}
int main()
{
freopen("C:\\in.txt","r",stdin);
int M,N;
while(scanf("%d %d",&M,&N)!=EOF){
if(M==-1&&N==-1)break;
for(int i=1;i<=N;i++){
scanf("%d %d",&food[i].J,&food[i].F);
}
qsort(food+1,N,sizeof(food[0]),cmp);

double sum=0;
for(int i=1;i<=N;i++){
if(M<food[i].F){
sum+=M*1.0/food[i].F*food[i].J;
break;
}
else{
M-=food[i].F;
sum+=food[i].J;
}
}
printf("%.3f\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: