您的位置:首页 > 其它

1047. Student List for Course (25)

2014-02-07 20:12 477 查看
Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters
plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students'
names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1


解题思路:感觉比上次的Course List for Student (25)那题简单,主要的考点还是时间瓶颈

string类型的数据集合操作比int型花费的时间要多得多,此题关键把string类型通过数组node[]映射成int 就能AC

ac参考代码:

#include <iostream>
#include <vector>
#include <algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;
int N,K;
struct Node{
char name[20];
};
vector<vector<int> > course(2501);
vector<Node> node;
bool compare(int a,int b){
return strcmp(node[a].name, node[b].name)<0;
}
int main()
{
scanf("%d%d",&N,&K);
node.resize(N);
for(int i=0;i<N;i++){
int n;
scanf("%s%d",&node[i].name,&n);
for(int j=0;j<n;j++){
int index;
scanf("%d",&index);
course[index-1].push_back(i);
}
}
for(int i=0;i<K;i++){
printf("%d %d\n",i+1,course[i].size());
sort(course[i].begin(),course[i].end(),compare);
for(int j=0;j<course[i].size();j++){
printf("%s\n",node[course[i][j]].name);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: