您的位置:首页 > 编程语言 > C语言/C++

Pat(Advanced Level)Practice--1003(Emergency)

2014-02-07 18:03 453 查看

Pat1003代码

题目描述:

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked
on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in
and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected
by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.

All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output
2 4


题目是求最短路径数和最大权重和。。。
AC代码:
/*
解题思想:
先进行最短路径算法,找出最短路径
再进行深搜,若等于最短路径,则计数加一
并累计最大救援数
*/
#include<cstdio>
#define MAX 501
#define INF 0x0FFFFFFF

int visited[MAX];
int map[MAX][MAX];
int dis[MAX],team[MAX];
int paths=0,helpers=0;

void Init()
{
int i,j;
for(i=0;i<MAX;i++)
{
visited[i]=0;
dis[i]=INF;
team[i]=0;
for(j=0;j<MAX;j++)
{
map[i][j]=INF;
map[j][i]=INF;
if(i==j)
map[i][j]=0;
}
}
}

void Dijkstra(int v,int n)
{
int i,j,min,index;
for(i=0;i<n;i++)
dis[i]=map[v][i];
visited[i]=1;
for(i=0;i<n-1;i++)
{
min=INF;
for(j=0;j<n;j++)
if(!visited[j]&&dis[j]<min)
{
min=dis[j];
index=j;
}
visited[index]=1;
for(j=0;j<n;j++)
{
if(map[index][j]<INF&&dis[j]>map[index][j]+dis[index])
dis[j]=dis[index]+map[index][j];
}
}
}

void DFS(int n,int s,int d,int curdis,int curnum)
{
int i;
visited[s]=1;
if(s==d)
{
if(curdis==dis[d])
{
paths++;
if(curnum>helpers)
helpers=curnum;
}
return;
}
if(curdis>dis[d])//当前路径超过最短路径,停止搜索
return;
for(i=0;i<n;i++)
{
if(!visited[i]&&map[s][i]<INF)//城市i未被访问,且c联通到i
{
DFS(n,i,d,curdis+map[s][i],curnum+team[i]);
visited[i]=0;
}
}
}

int main(int argc,char *argv[])
{
int N,M,S,D;
int C1,C2;
int i,j,len;
scanf("%d%d%d%d",&N,&M,&S,&D);
Init();
for(i=0;i<N;i++)
scanf("%d",&team[i]);
for(i=0;i<M;i++)
{
scanf("%d%d%d",&C1,&C2,&len);
map[C1][C2]=len;
map[C2][C1]=len;
}
Dijkstra(S,N);
for(i=0;i<N;i++)
visited[i]=0;
DFS(N,S,D,0,team[S]);
printf("%d %d\n",paths,helpers);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Advance Pat C++ Dijkstra DFS