您的位置:首页 > 其它

POJ 1703 Find them, Catch them(并查集)

2014-02-06 23:24 429 查看
简单的并查集类似 食物链那道题。 简单一下

设a-x, a-y 表示 a属于龙帮和a属于蛇帮,以此来判断从属关系

题目:

Find them, Catch them

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 27729Accepted: 8453
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City,
numbered from 1 to N. And of course, at least one of them belongs to
Gang Dragon, and the same for Gang Snake. You will be given M (M <=
10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The
first line of the input contains a single integer T (1 <= T <=
20), the number of test cases. Then T cases follow. Each test case
begins with a line with two integers N and M, followed by M lines each
containing one message as described above.
Output

For
each message "A [a] [b]" in each case, your program should give the
judgment based on the information got before. The answers might be one
of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source

POJ Monthly--2004.07.18

代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
using namespace std;

int N,M;
int f[2*100000+10];

void init()
{
for(int i=1;i<=2*N;i++)
{
f[i] = i;
}
}

int find( int x)
{
return f[x] == x? x: f[x] = find(f[x]);
}

int a,b;
char c;
void readin()
{
getchar();
c = getchar();scanf("%d%d",&a,&b);
}
bool same ( int a, int b)
{
int fa  = find(a) , fb =find( b);
if( fa == fb)return true;
return false;
}

void uni(int a,int b)
{
int fa = find(a), fb = find(b);
if( fa != fb)
f[fb] = fa;
}

int main()
{
int T;
cin>>T;
while(T--)
{
cin>>N>>M;
init();
for(int i=0;i<M;i++)
{
readin();

if(c == 'A')
{
if (same ( a, b ) || same( a+N , b+N))
cout<<"In the same gang."<<endl;
else if( same( a, b+N) || same(b, a+N))
cout<<"In different gangs."<<endl;
else
cout<<"Not sure yet."<<endl;
}
if( c== 'D')
{
uni ( a, b+N  );
uni ( b, a+N);
}

}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: