您的位置:首页 > 其它

[母函数]HDU 1171 Big Event in HDU

2014-02-06 21:40 471 查看
传送门:Big Event in HDU


Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 20346    Accepted Submission(s): 7135


Problem Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).

 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the
facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.

 

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

 

Sample Input

2
10 1
20 1
3
10 1
20 2
30 1
-1

 

Sample Output

20 10
40 40

 

Author

lcy

 

解题报告:

此题可用母函数解,代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int c1[250010],c2[250010];
int value[55];
int a[55];
int main(){
int n;
while(scanf("%d",&n)&&n>0){
memset(value,0,sizeof(value));
memset(a,0,sizeof(a));
int sum = 0;
for(int i=1;i<=n;i++){
scanf("%d%d",&value[i],&a[i]);
sum+=value[i]*a[i];
}
memset(c1,0,sum*sizeof(c1[0]));
memset(c2,0,sum*sizeof(c2[0]));
for(int i=0;i<=value[1]*a[1];i+=value[1])
c1[i]=1;
int len=value[1]*a[1];
for(int i=2;i<=n;i++){
for(int j=0;j<=len;j++)
for(int k=0;k<=value[i]*a[i];k+=value[i])
c2[k+j]+=c1[j];
len+=value[i]*a[i];
for(int j=0;j<=len;j++){
c1[j]=c2[j];
c2[j]=0;
}
}
for(int i=sum/2;i>=0;i--)
if(c1[i]!=0){
printf("%d %d\n", sum-i, i);
break;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  母函数