您的位置:首页 > 其它

[母函数]HDU 1398 Square Coins

2014-02-06 20:28 411 查看
传送门:Square Coins


Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7181    Accepted Submission(s): 4865


Problem Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are
available in Silverland. 

There are four combinations of coins to pay ten credits: 

ten 1-credit coins,

one 4-credit coin and six 1-credit coins,

two 4-credit coins and two 1-credit coins, and

one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

 

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

 

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 

 

Sample Input

2
10
30
0

 

Sample Output

1
4
27

 

Source

Asia 1999, Kyoto (Japan)

 

解题报告:

母函数模板题,只不过是平方次增加而已。代码如下:

#include<iostream>
#include<cstdio>
using namespace std;
int c1[310], c2[310];
int main(){
int n;
int i, j, k;
while(scanf("%d",&n)==1&&n){
for(i=0;i<=n;i++){
c1[i]=1;
c2[i]=0;
}
for(i=2; i*i<=n; i++){
for(j=0; j<=n; ++j)
for(k=0; k+j<=n; k+=i*i)
c2[j+k] += c1[j];
for(j=0; j<=n; ++j){
c1[j] = c2[j];
c2[j] = 0;
}
}
printf("%d\n",c1
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  母函数