您的位置:首页 > 大数据 > 人工智能

搜索 HOJ 1357 Calling Extraterrestrial Intelligence Again

2014-02-06 11:42 471 查看


Calling Extraterrestrial Intelligence Again

My Tags  (Edit)
 Source : ACM
ICPC Kanazawa(Japan) Regional Contest 2002
 Time limit : 1 sec Memory limit : 32 M
Submitted : 134, Accepted :
64

A message from humans to extraterrestrial intelligence was sent through the Arecibo radio telescope in Puerto Rico on the afternoon of Saturday November 16, 1974. The message consisted of 1679 bits and was meant to be translated to a rectangular picture with
23 * 73 pixels. Since both 23 and 73 are prime numbers, 23 * 73 is the unique possible size of the translated rectangular picture each edge of which is longer than 1 pixel. Of course, there was no guarantee that the receivers would try to translate the message
to a rectangular picture. Even if they would, they might put the pixels into the rectangle incorrectly. The senders of the Arecibo message were optimistic.

We are planning a similar project. Your task in the project is to find the most suitable width and height of the translated rectangular picture. The term "most suitable" is defined as follows. An integer m greater than 4 is given. A positive fraction a / b
less than or equal to 1 is also given. The area of the picture should not be greater than m. Both of the width and the height of the translated picture should be prime numbers. The ratio of the width to the height should not be less than a / b nor greater
than 1. You should maximize the area of the picture under these constraints.

In other words, you will receive an integer m and a fraction a / b. It holds that m > 4 and 0 < a / b < 1. You should find the pair of prime numbers p, q such that pq <= m and a / b <= p / q <= 1, and furthermore, the product pq takes the maximum value among
such pairs of two prime numbers. You should report p and q as the "most suitable" width and height of the translated picture.

Input

The input is a sequence of at most 2000 triplets of positive integers, delimited by a space character in between. Each line contains a single triplet. The sequence is followed by a triplet of zeros, 0 0 0, which indicated the end of the input and should not
be treated as data to be processed.

The integers of each input triplet are the integer m, the numerator a, and the denominator b described above, in this order. You may assume 4 < m <= 100000 and 1 <= a <= b <= 1000.

Output

The output is a sequence of pairs of positive integers. The i-th output pair corresponds to the i-th input triplet. The integers of each output pair are the width p and the height q described above, in this order.

Each output line contains a single pair. A space character is put between the integers as a delimiter. No other characters should appear in the output.

Sample Input
5 1 2
99999 999 999
1680 5 16
1970 1 1
2002 4 11
0 0 0

Sample Output
2 2
313 313
23 73
43 43
37 53


题意:给出了m,a,b,求最大的p*q 满足p*q <= m 且 p <= q 且 a/b <= p/q且p,q都是素数

思路:首先弄一个素数表,然后我们慢慢枚举,用二分找到最后一个不比m/2大的素数,这个数是p,然后从比p大的素数找到最后一个不比min(m/p,p*b/a)大的素数,这个是q,然后一直枚举下去,看哪一个最大。。。

代码:
#include <vector>
#include<cstdio>
#include<string.h>
#include<cstring>
#include <string>
#include <iostream>
#include <algorithm>
#include <cassert>
#include<math.h>
using namespace std;
#define eps 1e-8
#define LL long long
const int maxn = 50000+10;
int prime[maxn];
bool is_prime[maxn];
int sz;

int m , p , q , a , b;
double ab , pq;
void GetPrime()
{
sz = 0;
is_prime[1] = false;
for (int i = 2 ; i < maxn ; ++i) is_prime[i] = true;
for (int i = 2 ; i < maxn ; ++i)
{
if (is_prime[i]) prime[sz++] = i;
for (int j = 0 ; j < sz ; ++j)
{
if (prime[j]*i >= maxn) break;
is_prime[prime[j]*i] = false;
if (!(i%prime[j])) break;
}
}
}

int Bisearch(int left,int right,int x)
{
int mid = (left+right)>>1;
while (left<=right)
{
if (prime[mid] <= x) left = mid+1;
else right = mid-1;
mid = (left+right)>>1;
}
return left;
}

int main()
{
GetPrime();
while (scanf("%d%d%d",&m,&a,&b)==3)
{
if (m+a+b==0) return 0;
ab = (double)a/b+eps;
int pp = Bisearch(0,sz-1,(double)m/2+eps);
--pp;
int ans = 1;
int qq;
int ans_p , ans_q;
while (pp >= 0)
{
p = prime[pp];
qq = Bisearch(pp,sz-1,min((double)m/p+eps,(double)p*b/a+eps));
--qq;
if (qq < 0)
{
--pp;
continue;
}
--pp;
q = prime[qq];
if (q < p) continue;
if (ans < p*q)
{
ans = p*q;
ans_p = p;
ans_q = q;
}
}
printf("%d %d\n",ans_p,ans_q);
}
}


 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: