您的位置:首页 > 其它

搜索 HOJ 1692 Choose Your Own Adventure

2014-02-06 11:35 399 查看


Choose Your Own Adventure

My Tags  (Edit)
 Source : ACM
ICPC South Central USA 2004
 Time limit : 1 sec Memory limit : 32 M
Submitted : 52, Accepted :
29

After reading the book Tim and Marc Kill Kenny about fifty zillion times, James decided he'd had it with choose-your-own-adventure stories.
No matter what choices he made, it seemed like Kenny always fell down an abandoned mine shaft, got run over by a bus load of nuns, or was messily devoured by stray cats. James eventually found the page with the happy ending (where Kenny saves himself by trapping
Tim and Marc between the pizza and the hungry programmers) by flipping through the book, but he can't figure out how to get there by following the rules. Luckily, he owns a C compiler...

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets, each representing a choose-your-own-adventure story. Each data set will be formatted according to the following description, and there will be no
blank lines
 separating data sets.

The first line contains a single integer n indicating the number of data sets.

A single data set has 2 components:

Page Count - A line containing a single integer X,
where 1 < X < 100, indicating the number of pages in the story.

Page List - A sequence of X lines,
each of which represents a page from the book. Each line has the following components separated from one another by single spaces:

Line type - A single character indicating what type of line this is. It will represent either a "C" choice page, or an "E" end page. Page
1 is always a choice page.

Text - A string of text surrounded by double quotes. Including the quotes, this component will not exceed 256 characters. The quotes are
given for input purposes only and should not be considered part of the text. The text will not contain embedded double quotes.

Choices - Two positive integers from 1 to X indicating
the pages where the reader can go from this page. Only choice pages have this component.

Ending Type - Either the text "HAPPY" or "GRISLY". There will only be one happy ending per story, and only end pages have this component.

Output

For each story in the input:

Output a single line, "STORY #" where # is 1 for the first story, 2 for the second story, etc.

Determine the story that begins on page 1 and ends on the happy ending page. Output the text of this story, printing one "page" of text per line. Note that there is only one such story for each data set.

Sample Input
2
3
C "Arrived at LSU for the contest" 2 3
E "Was devoured by sidewalk ants" GRISLY
E "Won the contest. Received glory and nachos." HAPPY
5
C "Saw a peanut" 3 5
E "Made peanut butter sandwich" HAPPY
C "Found a hammer" 4 2
E "Hit self on head with hammer, ouch!" GRISLY
E "Ate the peanut, choked on it, and died" GRISLY

Sample Output
STORY 1
Arrived at LSU for the contest
Won the contest. Received glory and nachos.
STORY 2
Saw a peanut
Found a hammer
Made peanut butter sandwich


题意:有一本书,知道了某些页的内容,然后知道这一页能跳到哪一页。问怎么组织出一个happy ending ^_^

思路:直接深搜就可以了,没难度吧。

代码:
#include <iostream>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <string>
#include <string.h>
#include<queue>
#include<set>
using namespace std;
#define LL long long

struct Page
{
char content[256];
bool happy;
}page[110];
int n , ans[110] , top;
bool vis[110];
vector<int> G[110];

void init()
{
memset(page,0,sizeof(page));
for (int i = 1 ; i <= n ; ++i) G[i].clear();
top = 0;
memset(vis,0,sizeof(vis));
}

char buffer[300];
void input()
{
for (int i = 1 ; i <= n ; ++i)
{
scanf("%s",buffer);
if (buffer[0]=='C')
{
char ch = getchar();
while (ch!='"') ch = getchar();
while (scanf("%s",buffer+1))
{
buffer[0] = ' ';
strcat(page[i].content,buffer);
if (buffer[strlen(buffer)-1]=='"')
{
page[i].content[strlen(page[i].content)-1]= '\0';
break;
}
}
gets(buffer);
char * p = strtok(buffer , " ");
while (p)
{
int x;
sscanf(p,"%d",&x);
G[i].push_back(x);
p = strtok(NULL," ");
}
page[i].happy = false;
}
else if (buffer[0]=='E')
{
char ch = getchar();
while (ch!='"') ch = getchar();
while (scanf("%s",buffer+1))
{
buffer[0] = ' ';
strcat(page[i].content,buffer);
if (buffer[strlen(buffer)-1]=='"')
{
page[i].content[strlen(page[i].content)-1]= '\0';
break;
}
}
scanf("%s",buffer);
if (!strcmp(buffer,"HAPPY"))
page[i].happy = true;
else
page[i].happy = false;
}
}
}

bool dfs(int x)
{
if (vis[x]) return false;
ans[top++] = x;
if (page[x].happy) return true;
vis[x] = true;
for (int i = 0 ; i < G[x].size() ; ++i)
{
int y = G[x][i];
if (dfs(y)) return true;
}
--top;
return false;
}

void solve()
{
dfs(1);
for (int i = 0 ; i < top ; ++i)
printf("%s\n",page[ans[i]].content+1);
}

int main()
{
int T;
cin>>T;
for (int Cas = 1 ; Cas <= T ; ++Cas)
{
scanf("%d",&n);
init();
input();
printf("STORY %d\n",Cas);
solve();
}
}


 

 

 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: