您的位置:首页 > 其它

POJ 2342 简单树形dp

2014-02-06 03:30 405 查看
Anniversary party

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3719 Accepted: 2080
Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V.
E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating)
attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number
in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:

L K

It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line

0 0

Output
Output should contain the maximal sum of guests' ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output
5


子节点与父节点不能同时选,求权值,简单树形dp

dp[u][0]表示当前节点不选,dp[u][1]表示当前节点选。

状态方程:dp[u][0]+=max(dp[v][0],dp[v][1])表示当前节点不选时叠加子节点选与不选的最大值。

                    dp[u][1]+=dp[v][0],表示当前节点选时,子节点不选。

代码:

/* ***********************************************
Author :xianxingwuguan
Created Time :2014-2-6 3:11:18
File Name :3.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define pi acos(-1.0)
typedef long long ll;
const int maxn=10001;
int head[maxn],weight[maxn],dp[maxn][2],tol;
struct node{
int next,to;
}edge[2*maxn];
void add(int u,int v){
edge[tol].to=v;
edge[tol].next=head[u];
head[u]=tol++;
}
void dfs(int u,int fa){
dp[u][1]=weight[u];
for(int i=head[u];i!=-1;i=edge[i].next){
int v=edge[i].to;
if(v==fa)continue;
dfs(v,u);
dp[u][1]+=dp[v][0];
dp[u][0]+=max(dp[v][1],dp[v][0]);
}
}
int main()
{
//freopen("data.in","r",stdin);
//freopen("data.out","w",stdout);
int i,j,k,m,n;
while(~scanf("%d",&n)){
memset(head,-1,sizeof(head));tol=0;
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++)
scanf("%d",&weight[i]);
while(~scanf("%d%d",&i,&j)&&i&&j){
add(i,j);
add(j,i);
}
dfs(1,-1);
//cout<<"hahha"<<endl;
printf("%d\n",max(dp[1][0],dp[1][1]));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: