您的位置:首页 > 其它

[floyd]POJ 3615 Cow Hurdles

2014-02-05 22:04 459 查看
传送门:Cow Hurdles

Cow Hurdles

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5488 Accepted: 2436
Description

Farmer John wants the cows to prepare for the county jumping competition, so Bessie and the gang are practicing jumping over hurdles. They are getting tired, though, so they want to be able to use as little energy as possible to jump over the hurdles.

Obviously, it is not very difficult for a cow to jump over several very short hurdles, but one tall hurdle can be very stressful. Thus, the cows are only concerned about the height of the tallest hurdle they have to jump over.

The cows' practice room has N (1 ≤ N ≤ 300) stations, conveniently labeled 1..N. A set of M (1 ≤ M ≤ 25,000) one-way paths connects pairs of stations; the paths are also conveniently labeled 1..M. Path i travels
from station Si to station Ei and contains exactly one hurdle of height Hi (1 ≤ Hi ≤ 1,000,000). Cows must jump hurdles in any path they traverse.

The cows have T (1 ≤ T ≤ 40,000) tasks to complete. Task i comprises two distinct numbers, Ai and Bi (1 ≤ Ai ≤ N; 1 ≤ Bi ≤ N), which
connote that a cow has to travel from station Ai to station Bi (by traversing over one or more paths over some route). The cows want to take a path the minimizes the height of the tallest hurdle they jump over when traveling
from Ai to Bi . Your job is to write a program that determines the path whose tallest hurdle is smallest and report that height.

 

Input

* Line 1: Three space-separated integers: N, M, and T

* Lines 2..M+1: Line i+1 contains three space-separated integers: Si , Ei , and Hi 

* Lines M+2..M+T+1: Line i+M+1 contains two space-separated integers that describe task i: Ai and Bi

Output

* Lines 1..T: Line i contains the result for task i and tells the smallest possible maximum height necessary to travel between the stations. Output -1 if it is impossible to travel between the two stations.

Sample Input
5 6 3
1 2 12
3 2 8
1 3 5
2 5 3
3 4 4
2 4 8
3 4
1 2
5 1

Sample Output
4
8
-1

Source

USACO 2007 November Silver

解题报告:

此题可用floyd来做,但是需要scanf,printf来输入输出,cin,cout超时。代码如下:

#include<iostream>
#include<cstring>
#include<cstdio>
#define INF 0x7fffffff
using namespace std;
int weight[305][305];
int n,m,s;
void floyd(){
for(int t=1;t<=n;t++)
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++){
int tmp=max(weight[i][t],weight[t][j]);
weight[i][j]=min(tmp,weight[i][j]);
}
}
int main(){
while(scanf("%d%d%d",&n,&m,&s)==3){
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++)
weight[i][j]=INF;
weight[i][i]=0;
}
int a,b,v;
for(int i=1;i<=m;i++){
scanf("%d%d%D",&a,&b,&v);
weight[a][b]=v;
}
floyd();
int x,y;
for(int i=0;i<s;i++){
scanf("%d%d",&x,&y);
if(weight[x][y]==INF)
printf("-1\n");
else
printf("%d\n",weight[x][y]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  floyd