您的位置:首页 > 其它

Uva OJ 401 Palindromes 镜像串与回文串

2014-02-05 21:17 309 查看
西班牙大学Uvaoj401题

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left
to right as when the string is read from right to left.

A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored
string because "A" and "I" are their own reverses, and "3" and "E"are each others' reverses.

A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and
because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A", "T", "O", and "Y" are all their own reverses.

A list of all valid characters and their reverses is as follows.

CharacterReverseCharacterReverseCharacterReverse
AAMMYY
B N Z5
C OO11
D P 2S
E3Q 3E
F R 4 
G S25Z
HHTT6 
IIUU7 
JLVV88
K WW9 
LJXX  
Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input 

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output 

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

STRINGCRITERIA
" -- is not a palindrome."if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome."if the string is a palindrome and is not a mirrored string
" -- is a mirrored string."if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome."if the string is a palindrome and is a mirrored string
Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.
In addition, after each output line, you must print an empty line.

Sample Input 

NOTAPALINDROME
ISAPALINILAPASI
2A3MEAS
ATOYOTA


Sample Output 

NOTAPALINDROME -- is not a palindrome.

ISAPALINILAPASI -- is a regular palindrome.

2A3MEAS -- is a mirrored string.

ATOYOTA -- is a mirrored palindrome.

注意在判断镜像串时的处理技巧哦~~


#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
using namespace std;
int pal(char *x)
{
int i,n;
n=strlen(x);
for(i=0;i<n/2;i++)
if(x[i]!=x[n-1-i])
{
return 0;
break;
}
return 1;
}
int mirror(char *x,char *p,char *q)
{
int i,j,n,m;
n=strlen(x);
m=strlen(p);
for(i=0; i<(n+1)/2; i++)
for(j=0;j<m;j++)
{
if(x[i]==p[j]&&x[n-1-i]==q[j])
break;
if(j==m-1)
return 0;
}
return 1;
}
int main()
{
char str[105], *p = "AEHIJLMOSTUVWXYZ12358";
char *q = "A3HILJMO2TUVWXY51SEZ8";;
while(~scanf("%s",str))
{
if(pal(str)&&mirror(str,p,q))
printf("%s -- is a mirrored palindrome.\n\n",str);
if((!pal(str))&&mirror(str,p,q))
printf("%s -- is a mirrored string.\n\n",str);
if(pal(str)&&(!mirror(str,p,q)))
printf("%s -- is a regular palindrome.\n\n",str);
if(!pal(str)&&(!mirror(str,p,q)))
printf("%s -- is not a palindrome.\n\n",str);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: