您的位置:首页 > 其它

uva 10003- Cutting Sticks (记忆化搜索)

2014-02-04 18:34 295 查看


  Cutting Sticks 
You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery, Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work requires
that they only make one cut at a time.

It is easy to notice that different selections in the order of cutting can led to different prices. For example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end. There are
several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6. Another choice could be cutting at 4, then at 2, then at 7. This
would lead to a price of 10 + 4 + 6 = 20, which is a better price.
Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.

Input 

The input will consist of several input cases. The first line of each test case will contain a positive number l that
represents the length of the stick to be cut. You can assume l < 1000. The next line will contain the number n (n <
50) of cuts to be made.
The next line consists of n positive numbers ci ( 0 < ci < l) representing the places where the cuts have to be done, given in strictly
increasing order.
An input case with l = 0 will represent the end of the input.

Output 

You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of cutting the given stick. Format the output as shown below.

Sample Input 

100
3
25 50 75
10
4
4 5 7 8
0


Sample Output 

The minimum cutting is 200.
The minimum cutting is 22.


Miguel Revilla 

2000-08-21

题意:一根棒子上面有n个要切的记号,每一次切费用是没切之前的长度。问你确定切割的顺序。使得总和最小。

题解:木棒的每一个节点有一个下标从1~n,dp[i][j]表示木棒是节点i到节点j木棒的最小费用。

然后每一次深搜如果已经走过的就返回。

#include<cstdio>
#include<cstring>
#include<math.h>
#include<algorithm>
#include<queue>
#define ll long long

using namespace std;

int dp[60][60];
int a[60];
int Min(int c,int b)
{
return c>b?b:c;
}
int DFS(int s,int e)
{
int i,var;
if(dp[s][e]!=-1)
return dp[s][e];
var = DFS(s+1,e)+a[e]-a[s];
for(i=s+2;i<e;i++)
var = Min(var,DFS(i,e)+a[e]-a[s]+DFS(s,i));
dp[s][e] = var;
return dp[s][e];
}
int main()
{
int len,n,i,j;
while(scanf("%d",&len) && len!=0)
{
scanf("%d",&n);
a[0] = 0;
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
a[n+1] = len;
n+=2;
//sort(a,a+n);
memset(dp,-1,sizeof(dp));
for(i=0;i<n-1;i++)
dp[i][i+1] = 0;
printf("The minimum cutting is %d.\n",DFS(0,n-1));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  动态规划 dfs 搜索