您的位置:首页 > 其它

hdu3853(概率DP求期望)

2014-02-03 17:29 393 查看
地址:http://acm.hdu.edu.cn/showproblem.php?pid=3853


LOOPS

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)

Total Submission(s): 1458    Accepted Submission(s): 594


Problem Description

Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.



The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the
right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!

At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power
she need to escape from the LOOPS.

 

Input

The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1,
c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF

 

Output

A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

 

Sample Input

2 2
0.00 0.50 0.50 0.50 0.00 0.50
0.50 0.50 0.00 1.00 0.00 0.00

 

Sample Output

6.000

 

题意:问从(1,1)到(r,c)的消耗的期望能量。

思路:简单的求期望概率DP,直接带入公式即可。

            需要注意一点:存在一块区域只能不断停留。

代码:

#include<cstdio>
#include<cstring>
#include<iostream>
//#include<algorithm>
using namespace std;
struct node{
double p[5];
};
node map[1010][1010];
double p[1010][1010];
int main()
{
int r,c;
while(scanf("%d%d",&r,&c)>0)
{
p[r][c]=0;
for(int i=1;i<=r;i++)
for(int j=1;j<=c;j++)
scanf("%lf%lf%lf",&map[i][j].p[1],&map[i][j].p[2],&map[i][j].p[3]);
for(int i=r;i>0;i--)
for(int j=(i==r?c-1:c);j>0;j--)
{
if(map[i][j].p[1]==1) continue;  //只能停留的区域
p[i][j]=(p[i][j+1]*map[i][j].p[2]+p[i+1][j]*map[i][j].p[3]+2)/(1-map[i][j].p[1]);
}
printf("%.3lf\n",p[1][1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dp hdu