您的位置:首页 > 其它

最小公倍数

2014-02-03 17:23 260 查看
Least Common Multiple

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 13   Accepted Submission(s) : 6

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the
number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1


Sample Output

105
10296


 

我所知道的求最小公倍数方法:

先辗转相除法求出最大公约数。然后根据关系求出最小公倍数:最小公倍数=(a*b)/最大公约数

#include<iostream>
using namespace std;
int main()
{
int k;
int a[10000];
int lcm(int a,int b);
cin>>k;
while(k--)
{
int m;
cin>>m;
int i;
for(i=0;i<m;i++)
cin>>a[i];
int t;
t=a[0];
for(i=1;i<m;i++)
{
t=lcm(t,a[i]);
}
cout<<t<<endl;
}
return 0;
}
int lcm(int a,int b)
{
int gcd(int a,int b);
return a/gcd(a,b)*b;
}
int gcd(int a,int b)
{
if(b==0)
return a;
return gcd(b,a%b);
}

更多解法:

优秀学长的总结: http://blog.csdn.net/lulipeng_cpp/article/details/7423814
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Least Common Multipl