您的位置:首页 > 其它

USACO Number Triangles

2014-02-02 09:45 295 查看

Number Triangles

Consider the number triangle shown below. Write a program that calculates the highest sum of numbers that can be passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally
down to the left or diagonally down to the right.
7

3   8

8   1   0

2   7   4   4

4   5   2   6   5

In the sample above, the route from 7 to 3 to 8 to 7 to 5 produces the highest sum: 30.

PROGRAM NAME: numtri

INPUT FORMAT

The first line contains R (1 <= R <= 1000), the number of rows. Each subsequent line contains the integers for that particular row of the triangle. All the supplied integers are non-negative and no larger than
100.

SAMPLE INPUT (file numtri.in)

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

OUTPUT FORMAT

A single line containing the largest sum using the traversal specified.

SAMPLE OUTPUT (file numtri.out)

30


/*
ID: qhn9992
PROG: numtri
LANG: C++
*/
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

int a[1200][1200],dp[1200][1200];

int main()
{
freopen("numtri.in","r",stdin);
freopen("numtri.out","w",stdout);
int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
for(int j=0;j<=i;j++)
{
scanf("%d",&a[i][j]);
}
}

for(int i=0;i<n;i++)
{
for(int j=0;j<=i;j++)
{
int A=0,B=0;
if(i-1>=0)
{
if(j-1>=0) A=dp[i-1][j-1];
B=dp[i-1][j];
}
dp[i][j]=max(A,B)+a[i][j];
}
}

int ans=0;
for(int i=0;i<n;i++)
{
ans=max(ans,dp[n-1][i]);
}

printf("%d\n",ans);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: