您的位置:首页 > 其它

POJ 2106 Boolean Expressions

2014-02-02 06:57 176 查看
Boolean Expressions

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 3051Accepted: 934
Description

The objective of the program you are going to produce is to evaluate boolean expressions as the one shown next:

Expression: ( V | V ) & F & ( F | V )

where V is for True, and F is for False. The expressions may include the following operators: ! for not , & for and, | for or , the use of parenthesis for operations grouping is also allowed.

To perform the evaluation of an expression, it will be considered the priority of the operators, the not having the highest, and the or the lowest. The program must yield V or F , as the result for each expression in the input file.

Input

The expressions are of a variable length, although will never exceed 100 symbols. Symbols may be separated by any number of spaces or no spaces at all, therefore, the total length of an expression, as a number of characters, is unknown.

The number of expressions in the input file is variable and will never be greater than 20. Each expression is presented in a new line, as shown below.

Output

For each test expression, print "Expression " followed by its sequence number, ": ", and the resulting value of the corresponding test expression. Separate the output for consecutive test expressions with a new line.

Use the same format as that shown in the sample output shown below.

Sample Input
( V | V ) & F & ( F| V)
!V | V & V & !F & (F | V ) & (!F | F | !V & V)
(F&F|V|!V&!F&!(F|F&V))

Sample Output
Expression 1: F
Expression 2: V
Expression 3: V

Source

México and Central America 2004
(逆)波兰表达式 是栈的经典应用之一。

思路清晰的话,代码不会太长。

#include <iostream>
using namespace std;

const int N=110;
string s;
int val
,op
,vtop,otop;

void insert(int);
void calc();
int main()
{
int loop=0;
while (getline(cin,s)){
vtop=otop=0;
for (int i=0;i<s.size();++i)
switch(s[i]){
case '(':
op[otop++]=0;
break;
case ')':
while (otop && op[otop-1]!=0) calc();
--otop;
insert(val[--vtop]);
break;
case '!':
op[otop++]=3;
break;
case '&':
while (otop && op[otop-1]>=2) calc();
op[otop++]=2;
break;
case '|':
while (otop && op[otop-1]>=1) calc();
op[otop++]=1;
break;
case 'V':
insert(1);
break;
case 'F':
insert(0);
break;
default:
break;
}
while (otop) calc();
cout<<"Expression "<<++loop<<": "<<(val[0]?'V':'F')<<endl;
}
return 0;
}

void insert(int x){
while (otop && op[otop-1]==3){
x=!x; --otop;
}
val[vtop++]=x;
}

void calc(){
int a=val[--vtop];
int b=val[--vtop];
int o=op[--otop];
if (o==1)
insert(a|b);
else
insert(a&b);
}


kdwycz的网站: http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: