您的位置:首页 > 其它

POJ 3627 Bookshelf

2014-02-01 22:08 330 查看
[b]Bookshelf[/b]

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6990Accepted: 3506
[b]Description[/b]

Farmer John recently bought a bookshelf for cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

Each of the N cows (1 ≤ N ≤ 20,000) has some height of Hi (1 ≤ Hi ≤ 10,000) and a total height summed across all N cows of S. The bookshelf has a height of B (1 ≤ B ≤ S < 2,000,000,007).

To reach the top of the bookshelf taller than the tallest cow, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf. Since more cows than necessary in the stack can be dangerous, your job is to find the set of cows that produces a stack of the smallest number of cows possible such that the stack can reach the bookshelf.

[b]Input[/b]

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

[b]Output[/b]

* Line 1: A single integer representing the size of the smallest set of cows that can reach the bookshelf.

[b]Sample Input[/b]

6 40
6
18
11
13
19
11

[b]Sample Output[/b]

3

[b]Source[/b]

USACO 2007 December Bronze

给一些奶牛,给出它们各自的身高,求最少用多少头牛可以摞到比指定的高度更高

只要把所有牛的身高从高到底排序然后一个个依次相加直到达到标准即可

#include<iostream>
#include<cstdio>
#include<algorithm>

using namespace std;

bool cmp(int a,int b)
{
return a>b;
}

int main()
{
int n,b;
int cow[20010];

while(scanf("%d %d",&n,&b)==2)
{
for(int i=0;i<n;i++)
scanf("%d",&cow[i]);

sort(cow,cow+n,cmp);

int ans,sum=0;
for(ans=0;sum<b;ans++)
sum+=cow[ans];

printf("%d\n",ans);
}

return 0;
}


[C++]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: