您的位置:首页 > 其它

UVa 375 Inscribed Circles and Isosceles Triangles

2014-01-31 09:36 246 查看
Inscribed Circles and Isosceles Triangles
Given two real numbers

Bthe width of the base of an isosceles triangle in inchesHthe altitude of the same isosceles triangle in inches

Compute to six significant decimal places

Cthe sum of the circumferences of a series of inscribed circles stacked one on top of another from the base to the peak; such that the lowest inscribed circle is tangent to the base and the two sides and the next higher inscribed circle is tangent to the lowest inscribed circle and the two sides, etc. In order to keep the time required to compute the result within reasonable bounds, you may limit the radius of the smallest inscribed circle in the stack to a single precision floating point value of 0.000001.

For those whose geometry and trigonometry are a bit rusty, the center of an inscribed circle is at the point of intersection of the three angular bisectors.

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input will be a single line of text containing two positive single precision real numbers (B H) separated by spaces.

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.
The output should be a single real number with twelve significant digits, six of which follow the decimal point. The decimal point must be printed in column 7.

Sample Input

1

0.263451 0.263451

Sample Output

0.827648


三角形内部无限画内切圆直到半径小于0.000001,求这些内切圆的周长之和

此题的重点在于求三角形内心的位置,用到了下面这条性质:

  设三角形面积为S,三个边长分别为a,b,c,则内切圆半径为:2*S/(a+b+c)

此题中为等腰三角形,内心在底边的高线上,求出半径就求出了内心的位置,进而可以求下一个内心和下一个半径

#include<iostream>
#include<cstdio>
#include<cmath>
#define PI 3.1415926535897932384626

using namespace std;

int main()
{
int kase;

scanf("%d",&kase);

while(kase--)
{
double b,h;

scanf("%lf %lf",&b,&h);

double total=0;

while(true)
{
double tmp=sqrt(b*b/4+h*h);
double c=tmp*2+b;
double s=h*b;
double r=s/c;
if(r<0.000001)
break;
total+=r;
b-=2*r*b/h;
h-=2*r;
}

printf("%13.6f\n",2*PI*total);

if(kase)
putchar('\n');
}

return 0;
}


[C++]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: