您的位置:首页 > 其它

UVa 10392 Factoring Large Numbers

2014-01-31 08:46 330 查看

Problem F: Factoring Large Numbers

One of the central ideas behind much cryptography is that factoring large numbers is computationally intensive. In this context one might use a 100 digit number that was a product of two 50 digit prime numbers. Even with the fastest projected computers this factorization will take hundreds of years.

You don't have those computers available, but if you are clever you can still factor fairly large numbers.

Input

The input will be a sequence of integer values, one per line, terminated by a negative number. The numbers will fit in gcc's
long long int
datatype. You may assume that there will be at most one factor more than 1000000.

Output

Each positive number from the input must be factored and all factors (other than 1) printed out. The factors must be printed in ascending order with 4 leading spaces preceding a left justified number, and followed by a single blank line.

Sample Input

90
1234567891
18991325453139
12745267386521023
-1

Sample Output

2
3
3
5

1234567891

3
3
13
179
271
1381
2423

30971
411522630413


给一个不超过long long int范围的数求它的因数分解,数据保证大于1000000的因子只有一个

先求出1~1000000之间的所有素数,将输入的数从小到大分别除这些素数,如果能整除就将这个素数输出,并再接着除这个素数。全部除过之后如果还没除到1,那么剩下的这个结果就是那个大于1000000的素因子。

注意输出前要有4个空格,因为这个PE一次……

#include<iostream>
#include<cstdio>

using namespace std;

int prime[80000];
bool isprime[1000050];

int initial()
{
for(int i=0;i<=1000000;i++)
isprime[i]=true;
isprime[0]=isprime[1]=false;
for(int i=4;i<=1000000;i+=2)
isprime[i]=false;
for(int i=3;i<=1000;i++)
if(isprime[i])
for(int j=i*2;j<=1000000;j+=i)
isprime[j]=false;

int t=0;
for(int i=2;i<=1000000;i++)
if(isprime[i])
prime[t++]=i;

return t;
}

int main()
{
int t=initial();

long long x;

while( cin>>x && x>=0 )
{
for(int i=0;i<t;i++)
{
while(x%prime[i]==0)
{
printf("    %d\n",prime[i]);
x/=prime[i];
}
if(x==1)
break;
}

if(x>1)
cout<<"    "<<x<<endl<<endl;
else
printf("\n");
}

return 0;
}


[C++]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: