您的位置:首页 > 其它

[01背包]HDU 3466 Proud Merchants

2014-01-29 21:35 281 查看
传送门:Proud Merchants


Proud Merchants

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 2105    Accepted Submission(s): 833


Problem Description

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.

The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.

If he had M units of money, what’s the maximum value iSea could get?

 

Input

There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.

Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

Output

For each test case, output one integer, indicating maximum value iSea could get.

 

Sample Input

2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3

 

Sample Output

5
11

 

Author

iSea @ WHU

 

Source

2010 ACM-ICPC
Multi-University Training Contest(3)——Host by WHU

解题报告:

这题是01背包的变形。

题意:给出物品数量和拥有的资金,然后给出每样物品的价格,需要购买时至少需要的资金和物品本身的价值,求最大资金。

为了使购买的资金和价格相差不大,应该按照q-p排序。

状态转移方程:dp[j]=max(dp[j],dp[j-E[i].p]+E[i].v);

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct node{
int p,q,v;
}E[505];
int dp[5005];
bool cmp(const node &a,const node &b){
return a.q-a.p<b.q-b.p;
}
int main(){
int t,n;
while(scanf("%d%d",&t,&n)==2){
for(int i=0;i<t;i++)
scanf("%d%d%d",&E[i].p,&E[i].q,&E[i].v);
sort(E,E+t,cmp);
memset(dp,0,sizeof(dp));
for(int i=0;i<t;i++)
for(int j=n;j>=E[i].q;j--)
dp[j]=max(dp[j],dp[j-E[i].p]+E[i].v);
printf("%d\n",dp
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  DP 动态规划 01背包