您的位置:首页 > 其它

uva 116 Unidirectional TSP (dp)

2014-01-26 21:52 597 查看



Unidirectional TSP

Background

Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson
Problem (TSP) -- finding whether all the cities in a salesperson's route can be visited exactly once with a specified limit on travel time -- is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time
to generate, but are simple to check.

This problem deals with finding a minimal path through a grid of points while traveling only from left to right.

The Problem

Given an

matrix of integers, you are to write a program that computes a path of minimal
weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1 in an adjacent (horizontal or diagonal)
row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix ``wraps'' so that it represents a horizontal cylinder. Legal steps are illustrated below.



The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited.

For example, two slightly different

matrices are shown below (the only difference
is the numbers in the bottom row).



The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

The Input

The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by

integers
where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second
row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file.

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path's weight will exceed integer values representable using 30 bits.

The Output

Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of nintegers
(separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output.

Sample Input

5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 8 6 4
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 1 2 3
2 2
9 10 9 10


Sample Output

1 2 3 4 4 5
16
1 2 1 5 4 5
11
1 1
19


题目大意:

从最左边一列的一个位置出发到最右边一个位置,可以三个方向 (x+1,y) ,(x+1,y-1),(x+1,y+1) 经过的数字使之和最小,问你解决方案,输出逻辑位置最小的那一个。

解题思路:

这一题解题思路很明显二维DP可以搞定,但是记录路径逻最小,也就是从后往前DP ,找到第一列和最小的那个,也就是起点,那么从起点出发,根据记录的DP值很快找到路径。

代码:

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstdlib>
using namespace std;

const int inf=0x3f3f3f3f;
const int off[]={1,-1,0};
int r,c;
int a[20][200],dp[20][200];

void initial(){
for(int i=0;i<=r;i++)
for(int j=0;j<=c;j++)
dp[i][j]=inf;
}

void input(){
for(int i=0;i<r;i++){
for(int j=0;j<c;j++){
scanf("%d",&a[i][j]);
}
}
}

void computing(){
for(int i=0;i<r;i++) dp[i][c-1]=a[i][c-1];
for(int j=c-1;j>=1;j--){
for(int i=0;i<r;i++){
for(int t=0;t<3;t++){
int r0=(i+off[t]+r)%r;
if(dp[i][j]+a[r0][j-1]<dp[r0][j-1]){
dp[r0][j-1]=dp[i][j]+a[r0][j-1];
}
}
}
}
int ans=inf,route[200],pos=0;
for(int i=0;i<=c;i++) route[i]=inf;
for(int i=0;i<r;i++){
if(dp[i][0]<ans){
ans=dp[i][0];
pos=i;
}
}
route[0]=pos;
for(int j=1;j<c;j++){
int tmp=inf;
for(int t=0;t<3;t++){
int r0=(pos+off[t]+r)%r;
if(dp[r0][j]+a[pos][j-1]==dp[pos][j-1]){
if(r0<tmp) tmp=r0;
}
}
pos=tmp;
route[j]=pos;
}
for(int j=0;j<c;j++){
if(j>0) cout<<" ";
cout<<route[j]+1;
}
cout<<endl<<ans<<endl;
}

int main(){
//freopen("in.txt","r",stdin);
while(scanf("%d%d",&r,&c)!=EOF){
initial();
input();
computing();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: