您的位置:首页 > 其它

HDU1010(解题报告)

2014-01-16 15:09 190 查看
Tempter of the Bone

Time Limit:1000MS Memory Limit:32768KB 64bit
IO Format:
%I64d & %I64u

Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately
to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the
T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for
more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.



Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively.
The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;

'S': the start point of the doggie;

'D': the Door; or

'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.



Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.



Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0




Sample Output

NO
YES

思想:本题大意是输入n行m列,然后给出时间,问你能否在t时间内从S到达D。
     运用广搜算法和奇偶剪枝,首先在输入上,开一个字符串数组,让它做行循环,行每次循环后用里层循环使二维字符串数组map获得每个位置的相应字符,
     记录S和D的横纵坐标。在Dfs(广搜)中,用时间递减来限定,若果时间减到0,刚好S到达D,则把flag变为1,并且跳出,此时注意回溯,所以在外面要
     加一个flag=1的判断。奇偶剪枝注意两点,如果能够到达的话,需满足t大于D和S横坐标之差与纵坐标之差的绝对值(即从S到N的最短路径),并且,
     t减去S和D横纵坐标差的和的差应该是偶数。

解题代码:
#include <stdio.h>
#include <string.h>
#include <math.h>
int n,m,t;
int si,sj,di,dj,flag;
char map[1000][1000];
char str[1000];
int d[4][2]={0,1,1,0,0,-1,-1,0};
void Dfs(int si,int sj,int t)
{
    int i,nx,ny;
    if(flag==1)
        return;
    if(t<abs(si-di)+abs(sj-dj)||( (t-(abs(si-di)+abs(sj-dj))) %2!=0))
        return;
    if(t==0)
    {
        if(si==di&&sj==dj)
        {
            flag=1;
            return;
        }
        else
            return;
    }

    for(i=0;i<4;i++)
    {
        nx=si+d[i][0];
        ny=sj+d[i][1];
        if(nx<=n&&nx>=1&&ny<=m&&ny>=1&&(map[nx][ny]=='D'||map[nx][ny]=='.'))
        {
            map[nx][ny]='W';
            Dfs(nx,ny,t-1);
            map[nx][ny]='.';
        }
    }
    return;
}

int main()
{
    int i,j;
    while(scanf("%d%d%d",&n,&m,&t)!=EOF)
    {
        if(n==0&&m==0&&t==0)
            break;
        for(i=1;i<=n;i++)
        {
            scanf("%s",str);
            for(j=1;j<=m;j++)
            {
                map[i][j]=str[j-1];
                if(map[i][j]=='D')
                {
                    di=i;
                    dj=j;
                }
                if(map[i][j]=='S')
                {
                    si=i;
                    sj=j;
                }
            }
        }
        flag=0;
        Dfs(si,sj,t);
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: