您的位置:首页 > 其它

POJ2262(解题报告)

2014-01-16 10:21 351 查看
Goldbach's Conjecture

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 35436Accepted: 13591
Description
In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:

Every even number greater than 4 can be

written as the sum of two odd prime numbers.

For example:

8 = 3 + 5. Both 3 and 5 are odd prime numbers.

20 = 3 + 17 = 7 + 13.

42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)

Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million.

Input
The input will contain one or more test cases.

Each test case consists of one even integer n with 6 <= n < 1000000.

Input will be terminated by a value of 0 for n.
Output
For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes
adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input
8
20
42
0

Sample Output
8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

思想:本题大意为用户输入一偶数,把它写成两个奇素数输出,若果有多个解,取差值最大 的那组输出。
      对于素数,首先要明白除2外n内素数个数为[2,n/2]个,然后就是素数的判断,这里如果用常规算法一定会超时,所以选择若在[2,sqrt(n)]区间内,
      n/i==0,则是素数,这种算法据说时间复杂度时o(sqrt(n)),还是很快的。
     

解题代码:
#include <stdio.h>
#include <math.h>
int Judge(int x)
{
    int i;
    if(x%2==0)
        return 0;
    for(i=2;i<=sqrt(x);i++)
    {
        if(x%i==0)
            return 0;
    }
    return 1;
}

int main()
{
    int n,i,flag;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        flag=1;
        for(i=2;i<=n/2;i++)
        {
            if(Judge(i)&&Judge(n-i))
            {
                printf("%d = %d + %d\n",n,i,n-i);
                flag=0;
                break;
            }
        }
        if(flag)
            printf("Goldbach's conjecture is wrong.\n");
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: