您的位置:首页 > 其它

POJ 3278 Catch That Cow(BFS)

2014-01-13 19:24 411 查看
Catch That Cow

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 40350Accepted: 12560
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number
line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17

Sample Output
4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
题意:有一个农民和一头牛,他们在一个数轴上,牛在k位置保持不动,农户开始时在n位置。设农户当前在M位置,每次移动时有三种选择:1.移动到M-1;2.移动到M+1位置;3.移动到M*2的位置。问最少移动多少次可以移动到牛所在的位置。所以可以用广搜来搜索这三个状态,直到搜索到牛所在的位置。
#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;

const int N = 200100;
int n, k;
struct node
{
    int x, step;
};
queue<node> Q;
int vis
;

void BFS()
{   //搜索关于X的三种状态
    int X, STEP;
    while(!Q.empty())
    {
        node tmp = Q.front();
        Q.pop();
		X = tmp.x;
		STEP = tmp.step;
        if(X == k)
        {
            printf("%d\n",STEP);
            return ;
        }
        if(X >= 1 && !vis[X - 1]) //要保证减1后有意义,所以要X >= 1
        {
            node temp;
            vis[X - 1] = 1;
            temp.x = X - 1;
            temp.step = STEP + 1;
            Q.push(temp);
        }
        if(X <= k && !vis[X + 1])
        {
            node temp;
            vis[X + 1] = 1;
            temp.x = X + 1;
            temp.step = STEP + 1;
            Q.push(temp);
        }
        if(X <= k && !vis[X * 2])
        {
            node temp;
            vis[X * 2] = 1;
            temp.x = 2 * X;
            temp.step = STEP + 1;
            Q.push(temp);
        }
    }
}

int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        while(!Q.empty()) Q.pop();
        memset(vis,0,sizeof(vis));
        vis
 = 1;
        node t;
        t.x = n, t.step = 0;
        Q.push(t);
		BFS();
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: