您的位置:首页 > 产品设计 > UI/UE

POJ3094_Quicksum

2014-01-12 17:37 246 查看


Quicksum


Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^



题目描述

A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in
many other situations where it is necessary to detect undesirable changes in data. 

For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including
consecutive spaces.

A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example
Quicksum calculations for the packets "ACM" and "MID CENTRAL": 

        ACM: 1*1 + 2*3 + 3*13 = 46

MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12  =  650


输入

The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.


输出

For each packet, output its Quicksum on a separate line in the output.


示例输入

ACM
MID CENTRAL
REGIONAL PROGRAMMING CONTEST
ACN
A C M
ABC
BBC
#



示例输出

46
650
4690
49
75
14
15




解题报告
#include<stdio.h>
int main ()
{
char str[255];
int i,sum;
while(gets(str)!=NULL && str[0]!='\n' &&str[0]!='#')
{

sum=0;
for(i=0;str[i]!='\0';i++)
{
if(str[i]>='A'&&str[i]<='Z')
sum=sum+(i+1)*(str[i]-64);
else if(str[i]==' ')
sum=sum;
}
printf("%d\n",sum);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM SDUT1103 POJ3094