您的位置:首页 > 运维架构

小白dp uva 10271 - Chopsticks

2014-01-12 14:39 555 查看
Problem C
Chopsticks

Input:
 Standard Input
Output: Standard Output

In China, people use a pair of chopsticks to get food on the table, but Mr. L is a bit different. He uses a set of three chopsticks -- one pair, plus an EXTRA long chopstick to get some big food by piercing it through
the food. As you may guess, the length of the two shorter chopsticks should be as close as possible, but the length of the extra one is not important, as long as it's the longest. To make things clearer, for the set of chopsticks with lengths A,B,C(A<=B<=C),
(A-B)2 is called the 'badness' of the set.
It's December 2nd, Mr.L's birthday! He invited K people to join his birthday party, and would like to introduce his way of using chopsticks. So, he should prepare K+8 sets of chopsticks(for himself, his wife, his
little son, little daughter, his mother, father, mother-in-law, father-in-law, and K other guests). But Mr.L suddenly discovered that his chopsticks are of quite different lengths! He should find a way of composing the K+8 sets, so that the total badness of
all the sets is minimized.
Input
The first line in the input contains a single integer T, indicating the number of test cases(1<=T<=20). Each test case begins with two integers K, N(0<=K<=1000, 3K+24<=N<=5000), the number of guests and the number
of chopsticks. There are N positive integers Li on the next line in non-decreasing order indicating the lengths of the chopsticks.(1<=Li<=32000).
Output
For each test case in the input, print a line containing the minimal total badness of all the sets.
Sample Input
1

1 40

1 8 10 16 19 22 27 33 36 40 47 52 56 61 63 71 72 75 81 81 84 88 96 98 103 110 113 118 124 128 129 134 134 139 148 157 157 160 162 164

Sample Output
23

Note
For the sample input, a possible collection of the 9 sets is:
8,10,16; 19,22,27; 61,63,75; 71,72,88; 81,81,84; 96,98,103; 128,129,148; 134,134,139; 157,157,160

______________________________________________________________

题意:

从给定的组合中找出 (A,B,C)这样的k+8个组合,每个组合满足(A<=B<=C),badness为 (A-B)^2,使得总badness最小。

思路:

开始觉得C不用考虑,那就很好转移了,发现没有这么简单,因为C要满足最大,直接转移会使在你把A、B选好后,没有那么多C满足你的条件。从小到大转移不好控制,那就从大到小排序后转移了。

dp[i][j]-前j个数能选出i个组合   i-选第几个组合  j-前j个数

那么有

dp[i][j]=min(dp[i][j-2],dp[i-1][j-2]+(a[j]-a[j-1])^2);

当然取第二个时需满足 j>=3*i
啦。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 5005
#define MAXN 100005
#define mod 1000000007
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 0.000001
typedef long long ll;
using namespace std;

int n,m,ans,cnt,tot,flag;
int a[maxn],dp[2][maxn];

void solve()
{
int i,j,t,p=0;
memset(dp,0x3f,sizeof(dp));
for(i=0;i<=n;i++)
{
dp[0][i]=0;
}
for(i=1;i<=m;i++)
{
for(j=0;j<3*i;j++) dp[p^1][j]=INF;
for(j=3*i;j<=n;j++)
{
dp[p^1][j]=dp[p^1][j-1];
if(j>=3*i)
{
dp[p^1][j]=min(dp[p^1][j],dp[p][j-2]+(a[j]-a[j-1])*(a[j]-a[j-1]));
}
}
p=p^1;
}
ans=INF;
for(j=3*m;j<=n;j++)
{
ans=min(ans,dp[p][j]);
}
}
bool cmp(int x,int y)
{
return x>y;
}
int main()
{
int i,j,t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&m,&n);
m+=8;
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
sort(a+1,a+n+1,cmp);
solve();
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: