您的位置:首页 > 其它

HDU 1728逃离迷宫(DFS或者BFS)

2014-01-11 15:55 537 查看


逃离迷宫

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 12273    Accepted Submission(s): 2964


Problem Description

  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?

 

Input

  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,

  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x1, y1, x2, y2 (1 ≤ k ≤ 10, 1 ≤ x1, x2 ≤ n, 1 ≤ y1, y2 ≤
m),其中k表示gloria最多能转的弯数,(x1, y1), (x2, y2)表示两个位置,其中x1,x2对应列,y1, y2对应行。

 

Output

  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。

 

Sample Input

2
5 5
...**
*.**.
.....
.....
*....
1 1 1 1 3
5 5
...**
*.**.
.....
.....
*....
2 1 1 1 3

 

Sample Output

no
yes

 

DFS代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int m, n, ex, ey, k, p[105][105];
//p[x][y]代表某位置
char map1[105][105];
int x_move[4] = {-1, 0, 1, 0};
int y_move[4] = {0, 1, 0, -1};
bool flag;

void dfs (int x, int y, int dir) //dir为当前方向
{
if (x == ex && y == ey)
{
if (p[x][y] <= k)
flag = true;
return ;
}
//x !=ex && y != ey 说明必须至少再转一次弯,但是已经不能再转了
if ((x !=ex && y != ey && p[x][y] == k)||p[x][y]>k)
return ;
for (int i = 0; i < 4; i++)
{
int tx = x + x_move[i];
int ty = y + y_move[i];
if (tx < 0 || tx >= m|| ty < 0 || ty >= n)  //判断越界
continue;
//转弯数相等不可剪掉
if (map1[tx][ty] == '*' || p[tx][ty] < p[x][y])  //说明已经搜过或不可到达
continue;
if (dir != -1 && i != dir && p[tx][ty] == p[x][y] )
continue;          //需要剪枝
if (dir != -1 && i != dir)
p[tx][ty]=p[x][y]+1; //如果方向变了转弯+1
else p[tx][ty] = p[x][y];
dfs (tx, ty, i);
if (flag) return ;
}
}

int main()
{
int t,i,j,sx,sy; //sx, sy是起点
scanf ("%d", &t);
while (t--)
{
scanf("%d%d",&m,&n);
for(i=0;i<m;i++)
scanf ("%s",map1[i]);
scanf("%d%d%d%d%d",&k,&sy,&sx,&ey,&ex);
sx--,sy--,ex--,ey--;  //从0开始编号,而题目是从1开始
for (i = 0; i < m; i++)
for (j = 0; j < n; j++)
p[i][j] = 10005; //初始化转弯数为无穷大
p[sx][sy] = 0; //到达起点的转弯数
flag = false;
dfs (sx, sy, -1); //一开始可以走任意方向,所以设方向为-1
if (flag) puts ("yes");
else puts ("no");
}
return 0;
}


BFS代码:
#include<iostream>
#include<cstring>
#include<cstdio>
#include<map>
#include<string>
#include<queue>
using namespace std;
int enx,eny,m,n;
char mp[105][105];
int mstep;
int flag;
int visi[105][105];
int q[105][105];

int dir[4][2]={{-1,0},{1,0},{0,1},{0,-1}};
struct node
{
int x;
int y;
}nod;

void bfs(node p)
{
queue<node> mq;
mq.push(p);
node cur,pp;
int i;

while(!mq.empty())
{
cur=mq.front();
mq.pop();
if(q[cur.x][cur.y]>=mstep) break;

int px,py;
for(i=0;i<4;i++)
{
px=cur.x+dir[i][0],py=cur.y+dir[i][1];
while(px>=0&&px<m&&py>=0&&py<n)
{
if(mp[px][py]=='*')
break;
if(!visi[px][py])
{
visi[px][py]=1;
pp.x=px,pp.y=py;
q[px][py]=q[cur.x][cur.y]+1;
mq.push(pp);
}
px+=dir[i][0],py+=dir[i][1];
}
}
}
}

int main()
{
int stx,sty;
int tes,i,j;
cin>>tes;
while(tes--)
{
flag=0;
cin>>m>>n;
for(i=0;i<m;i++)
cin>>mp[i];
cin>>mstep;
cin>>stx>>sty>>enx>>eny;
stx--,sty--,enx--,eny--;
swap(stx,sty); swap(enx,eny);
node p;
p.x=stx,p.y=sty;
memset(visi,0,sizeof(visi));
for(i=0;i<m;i++)
for(j=0;j<n;j++)
q[i][j]=1e8;
visi[p.x][p.y]=1;
q[p.x][p.y]=-1;
bfs(p);

if(q[enx][eny]<=mstep) flag=1;
/*for(i=0;i<m;i++)
{
for(j=0;j<n;j++)
cout<<q[i][j]<<" ";
cout<<endl;
}
cout<<mstep<<endl;*/

if(flag) puts("yes");
else puts("no");
}
return 0;
}

//
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: