您的位置:首页 > 其它

POJ 1511 Invitation Cards 求来回最短路(spfa)

2014-01-08 17:16 471 查看
点击打开链接

Invitation Cards

Time Limit: 8000MS Memory Limit: 262144K
Total Submissions: 17776 Accepted: 5812
Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information
and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special
course was taken where students learned how to influence people and what is the difference between influencing and robbery. 

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait
until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting
and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program
that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number
of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which
is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.
Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.
Sample Input
2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output
46
210

Source

Central Europe 1998

给你n个点,m条边,让你求出从1号点到其余各个点的最短距离之和和其余各个点到1号点的最短距离之和。
数据太大,直接dijkstra或者floyd肯定会超时,除非优化,所以得用spfa来解决还必须得用邻接表存储,求1号点到其余各个点的距离之和容易求,而在求其余各个点到1号点的距离之和的时候就需要建反图,在来一次spfa就可以求出。
例如样列2的原图:




反图:


#include<algorithm>
#include<cstring>
#include<queue>
#include<cstdio>
#define MAXN 1000007
#define inf 0x3f3f3f3f
using namespace std;
long long dis[MAXN];          // dis[u] = d:从起点s到点u的路径长为d
int vis[MAXN];         // inq[u]:点u是否在队列中
int head[MAXN];
int NE,n;
int a[MAXN],b[MAXN],c[MAXN];
struct node
{
int v,cap,next;
} Edge[MAXN<<2];
void addEdge(int u,int v,int cap)
{
Edge[NE].v=v;
Edge[NE].cap=cap;
Edge[NE].next=head[u];
head[u]=NE++;
}
void init()
{
NE=0;
memset(head,-1,sizeof(head));
memset(vis,0,sizeof(vis));
for(int i=0;i<=n;i++) dis[i]=inf;
}
long long SPFA(int s)                   //  源点为0,汇点为sink。
{
long long count=0;
queue<int>q;
q.push(s);
dis[s] = 0;
vis[s] =1;
while(!q.empty())        //  这里最好用队列,有广搜的意思,堆栈像深搜。
{
int u =q.front();
q.pop();
for(int i=head[u]; i!=-1;i=Edge[i].next)
{
int v=Edge[i].v;
if(dis[v]>dis[u]+Edge[i].cap)
{
dis[v]=dis[u]+Edge[i].cap;
if(!vis[v])
{
q.push(v);
vis[v]=true;
}
}
}
}
for(int i=1;i<=n;i++)
count+=dis[i];
return count;
}
int main()
{

int m,cas;
scanf("%d",&cas);
while(cas--)
{
long long ans=0;
scanf("%d%d",&n,&m);
init();
for(int i=0;i<m;i++)
{
scanf("%d%d%d",&a[i],&b[i],&c[i]);
addEdge(a[i],b[i],c[i]);
}
ans+=SPFA(1);
init();
for(int i=0;i<m;i++)
addEdge(b[i],a[i],c[i]);
ans+=SPFA(1);
printf("%lld\n",ans);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: