您的位置:首页 > 其它

浙大2012机试题——Sharing

2014-01-08 16:24 351 查看
原题地址:http://ac.jobdu.com/problem.php?pid=1468

题目描述:

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.




Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).
输入:

For each case, the first line contains two addresses of nodes and a positive N (<= 10^5), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer,
and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

输出:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

样例输入:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

样例输出:
67890
-1

解题思路:题目本身并不难,仔细看题目可以发现只要找出输入的Node中出现两次一样的Next即可,   九度难度给五星估计是因为很容易超时。

之前尝试用c++ 的Algorithm的算法,如count,count_if,find_if均超时,后来采用list容器本身的sort方法AC。

源代码:

#include <iostream>
using namespace std;
#include <list>
#include <iomanip>

std::list<int> node_list;

int main()
{
int begin_addr1,begin_addr2,N;
int addr1,addr2;
char c;
std::list<int>::iterator it;
std::list<int>::iterator it1;
while(cin>>begin_addr1>>begin_addr2>>N)
{
node_list.resize(0);
for(int i=0;i<N;i++)
{
cin>>addr1>>c>>addr2;
node_list.push_back(addr2);
}
node_list.sort();
it=node_list.begin();
while(it!=node_list.end())
{
it1=it++;
if(*it1 == *it)
break;
}
if(*it1 != -1)
cout<<std::setfill('0')<<std::setw(5);
cout<<*it1<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  浙大 Sharing 九度 suffix