您的位置:首页 > 其它

uva624 CD(dp 0-1 背包 打印路径)

2014-01-01 18:45 387 查看
给出一个tape的最大时常,再给出一些CD的长度, 问最多能copy多少到tape上,要求打印哪些cd

要打印路径就在计算的时候记录一下前一个是什么, 然后递归打印 。。 注意tape最大时间设置大一点,一开始1000wa了

题目:

CD
You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How to choose tracks from CD to get most out of tape space and have as short unused space as possible.

Assumptions:

number of tracks on the CD. does not exceed 20

no track is longer than N minutes

tracks do not repeat

length of each track is expressed as an integer number

N is also integer

Program should find the set of tracks which fills the tape best and print it
in the same sequence as the tracks are stored on the CD


Input

Any number of lines. Each one contains value N, (after space) number of tracks
and durations of the tracks. For example from first line in sample data: N=5,
number of tracks=3, first track lasts for 1 minute, second one 3 minutes, next
one 4 minutes


Output

Set of tracks (and durations) which are the correct solutions and
string ``sum:" and sum of duration times.


Sample Input

5 3 1 3 4
10 4 9 8 4 2
20 4 10 5 7 4
90 8 10 23 1 2 3 4 5 7
45 8 4 10 44 43 12 9 8 2


Sample Output

1 4 sum:5
8 2 sum:10
10 5 4 sum:19
10 23 1 2 3 4 5 7 sum:55
4 10 12 9 8 2 sum:45

代码:


//Wed Jan  1 17:26:55 2014
//Author:Minshik
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <string>
#include <vector>
#include <set>
#include <stack>
#include <queue>
#include <deque>
#include <memory.h>
#include <cctype>
using namespace std;

int tape,tn;
int tracks[50];
int ans[2000];
int rec[2000][2000];
void printlol(int n,int c)
{
if(n==0) return ;
if(n==1 && rec
[c]>0){printf("%d ",rec
[c]);return;}

if(rec
[c]>0)
{
printlol(n-1,c-tracks
);
printf("%d ",tracks
);
}
else
printlol(n-1,c);
}
int main()
{
while(cin>>tape>>tn)
{
for(int i=1;i<=tn;i++)
{
cin>>tracks[i];
}

for(int i=1;i<=tn;i++)
{
for(int v=tape;v>=0;v--)
{
rec[i][v]=0;
if(v>=tracks[i])                //注意不要少等号
{
//ans[v] = max(ans[v],ans[v-tracks[i]]+tracks[i]);
if(ans[v]<ans[v-tracks[i]]+tracks[i])
{
ans[v] = ans[v-tracks[i]]+tracks[i];
rec[i][v] = tracks[i];
}
}
}
}
printlol( tn,tape );

cout<<"sum:"<<ans[tape]<<endl;
for(int i=0;i<=tape;i++)
{
ans[i]=0;
}
memset(rec,0,sizeof(rec));
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: