您的位置:首页 > 其它

hdu 1009:FatMouse' Trade(贪心)

2014-01-01 13:35 381 查看

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36632 Accepted Submission(s): 12064


[align=left]Problem Description[/align]
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

[align=left]Input[/align]
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

[align=left]Output[/align]
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

[align=left]Sample Input[/align]

5 3

7 2

4 3

5 2

20 3

25 18

24 15

15 10

-1 -1

[align=left]Sample Output[/align]

13.333

31.500

[align=left]Author[/align]
CHEN, Yue

[align=left]Source[/align]
ZJCPC2004

[align=left]Recommend[/align]
JGShining | We have carefully selected several similar problems for you: 1050 1051 1052 1007 1049

水题,读不懂题意是个坑,英语是个大问题啊……

#include <iostream>
#include <iomanip>
using namespace std;

int main()
{
int N,M;
while(cin>>M>>N,M!=-1 || N!=-1){
int J[1001],F[1001];
for(int i=1;i<=N;i++){
cin>>J[i]>>F[i];
}
//ÅÅÐò
for(int i=1;i<=N-1;i++)
for(int j=1;j<=N-i;j++){
if((double)J[j]/F[j]<(double)J[j+1]/F[j+1]){
int t;
t=F[j];F[j]=F[j+1];F[j+1]=t;
t=J[j];J[j]=J[j+1];J[j+1]=t;
}
}
int fs=1,fe=1;

//¼ÆËã
double res=0;
for(int i=1;i<=N;i++){
if(M-F[i]>=0){
res+=J[i];
M-=F[i];
}
else{
res+=M/(double)F[i]*(double)J[i];
break;
}
}
cout<<setiosflags(ios::fixed);
cout<<setprecision(3);
cout<<res<<endl;
}
return 0;
}


Freecode : www.cnblogs.com/yym2013
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: