您的位置:首页 > 其它

Ant on a Chessboard

2013-12-30 14:17 363 查看
 Problem A.Ant on a Chessboard 
 

Background

  One day, an ant called Alice came to an M*M chessboard. She wanted to go around all the grids. So she began to walk along the chessboard according to this way: (you can assume that her speed is one grid per second)

  At the first second, Alice was standing at (1,1). Firstly she went up for a grid, then a grid to the right, a grid downward. After that, she went a grid to the right, then two grids upward, and then two grids to the left…in a word, the path was like a
snake.

  For example, her first 25 seconds went like this:

  ( the numbers in the grids stands for the time when she went into the grids)

25

24

23

22

21

10

11

12

13

20

9

8

7

14

19

2

3

6

15

18

1

4

5

16

17

5
4
3
2
1
 

1   2   3    4   5
At the 8th second , she was at (2,3), and at 20th second, she was at (5,4).

Your task is to decide where she was at a given time.

(you can assume that M is large enough)

 

Input

  Input file will contain several lines, and each line contains a number N(1<=N<=2*10^9), which stands for the time. The file will be ended with a line that contains a number 0.

 

Output

  For each input situation you should print a line with two numbers (x, y), the column and the row number, there must be only a space between them.

 

 

Sample Input

8

20

25

0

Sample Output

2 3

5 4

1 5

解题报告

思路是找到规律

这题是找规律

规律如下:

第一阶:1

第二阶:2, 3, 4

第三阶:9, 8, 7, 6, 5

以此类推

第i阶的中心数字, 也就是在转角的数字, 是 i*i - i + 1
#include<stdio.h>
int main()
{
int n,i,j,k;
while(scanf("%d",&n)!=EOF)
{
if(n==0)break;
for(i=1;;i++)
if(i*i>=n)break;
if(i%2==0)
{
if(n<=i*(i-1)+1)
{
for(k=1,j=i*i-2*i+2;j<=i*(i-1)+1;j++,k++)
{
if(j==n)
{
printf("%d %d\n",k,i);
break;
}
}
}
else
{
for(k=i,j=i*(i-1)+1;j<=i*i;j++,k--)
{
if(j==n)
{
printf("%d %d\n",i,k);
break;
}
}
}
}
else//奇数
{
if(n>=i*(i-1)+1)
{
for(k=1,j=i*i;j>=i*(i-1)+1;j--,k++)
{
if(j==n)
{
printf("%d %d\n",k,i);
break;
}
}
}
else
{
for(k=i,j=i*(i-1)+1;j>=i*i-2*i+2;j--,k--)
{
if(j==n)
{
printf("%d %d\n",i,k);
break;
}
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM UVA 10161