您的位置:首页 > 编程语言 > C语言/C++

Ant on a Chessboard

2013-12-29 20:07 281 查看

Background

  One day, an ant called Alice came to an M*M chessboard. She wanted to go around all the grids. So she began to walk along the chessboard according to this way: (you can assume that her speed is one grid per second)
  At the first second, Alice was standing at (1,1). Firstly she went up for a grid, then a grid to the right, a grid downward. After that, she went a grid to the right, then two grids upward, and then two grids to the left…in
a word, the path was like a snake.
  For example, her first 25 seconds went like this:
  ( the numbers in the grids stands for the time when she went into the grids)
 
25

24

23

22

21

10

11

12

13

20

9

8

7

14

19

2

3

6

15

18

1

4

5

16

17

5
4
3
2
1
 
1          2          3           4           5
At the 8th second , she was at (2,3), and at 20th second, she was at (5,4).
Your task is to decide where she was at a given time.
(you can assume that M is large enough)
 
 

Input

  Input file will contain several lines, and each line contains a number N(1<=N<=2*10^9), which stands for the time. The file will be ended with a line that contains a number 0.
 
 

Output

  For each input situation you should print a line with two numbers (x, y), the column and the row number, there must be only a space between them.
 
 

Sample Input

8
20
25
0
 
 

Sample Output

2 3
5 4
1 5
这个题,据说都是根据对角线的规律做的,我是根据1,4,9。。。。等平方数的特殊位置照的规律。凑合看吧。。

#include <stdio.h>
#include <math.h>
int main()
{
int x, y, c;
while(scanf("%d", &x)!=EOF)
{
if(x == 0) break;
y = (int)sqrt(x)+1.5;
c = y * y - x;
if(x == (y-1)*(y-1))
{
if(y % 2 == 0)
printf("1 %d\n", y-1);
else
printf("%d 1\n", y-1);
}
else
{
if(y % 2 == 1)
{
if(c > y - 1)
printf("%d %d\n", y, 2 * y - c - 1);
else
printf("%d %d\n", c + 1, y);
}
else
{
if(c > y - 1)
printf("%d %d\n", x - (y-1)*(y-1), y);
else
printf("%d %d\n", y, c + 1);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c语言 编程