您的位置:首页 > 其它

UVa401 - Palindromes-字符串(镜像字符串)-难度2

2013-12-25 14:56 246 查看
题目链接:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=342


  Palindromes 
A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right
to left.

A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored
string because "A" and "I" are their own reverses, and "3" and "E"are each others' reverses.

A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and
because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A", "T", "O", and "Y"are all their own reverses.

A list of all valid characters and their reverses is as follows.

CharacterReverseCharacterReverseCharacterReverse
AAMMYY
B N Z5
C OO11
D P 2S
E3Q 3E
F R 4 
G S25Z
HHTT6 
IIUU7 
JLVV88
K WW9 
LJXX  
Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input 

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output 

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

STRINGCRITERIA
" -- is not a palindrome."if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome."if the string is a palindrome and is not a mirrored string
" -- is a mirrored string."if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome."if the string is a palindrome and is a mirrored string
Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input 

NOTAPALINDROME
ISAPALINILAPASI
2A3MEAS
ATOYOTA


Sample Output 

NOTAPALINDROME -- is not a palindrome.

ISAPALINILAPASI -- is a regular palindrome.

2A3MEAS -- is a mirrored string.

ATOYOTA -- is a mirrored palindrome.


代码+思路

#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
#include <string>
using namespace std;

const int MAX = 150;
void Init(char *hash)
{
memset(hash, 0, sizeof(hash));//用hash保存映射关系
hash['A'] = 'A';
hash['E'] = '3';
hash['H'] = 'H';
hash['I'] = 'I';
hash['J'] = 'L';
hash['L'] = 'J';
hash['M'] = 'M';
hash['O'] = 'O';
hash['S'] = '2';
hash['T'] = 'T';
hash['U'] = 'U';
hash['V'] = 'V';
hash['W'] = 'W';
hash['X'] = 'X';
hash['Y'] = 'Y';
hash['Z'] = '5';
hash['1'] = '1';
hash['2'] = 'S';
hash['3'] = 'E';
hash['5'] = 'Z';
hash['8'] = '8';
}
int main()
{
#ifdef LOCAL
freopen("f:\\input.txt", "r", stdin);
//freopen("f:\\output1.txt", "w", stdout);
#endif
char hash[MAX];
Init(hash);
string s;
while(getline(cin, s))
{
int flag1 = 1, flag2 = 1, len = s.size();
for(int i = 0; i < len / 2; i++)
{
char a = s[i], b = s[len - i - 1];
if(a != b)
{
flag1 = 0;
break;
}
}

for(int i = len - 1; i >= 0; i--)
{
char a = s[i], b = s[len - 1 - i];
if(a == '0') a = 'O';
if(b == '0') b = 'O';//把0当成字母O
a = hash[a];
if(a != b)
{
flag2 = 0;
break;
}
}
if(flag1 == 1 && flag2 == 0)
cout << s << " -- is a regular palindrome.\n\n";
else if(flag1 == 0 && flag2 == 1)
cout << s << " -- is a mirrored string.\n\n";
else if(flag1 == 1 && flag2 == 1)
cout << s << " -- is a mirrored palindrome.\n\n";
else
cout << s << " -- is not a palindrome.\n\n";//注意输入要输出一个空行
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: