您的位置:首页 > 其它

poj 1276 Cash Machin(混合背包)

2013-12-23 22:01 204 查看


Cash Machine

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 25941Accepted: 9139
Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply
of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:

@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers
in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input
735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output
735
630
0
0


解题思路:

用混合背包解决,学习背包可以看看背包9讲


#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#define N 100005
int m,f
;
int Max(int a,int b)
{
return a>b?a:b;
}
void Zeroone(int c,int w)          // 01背包
{
int i;
for(i=m;i>=c;i--)
f[i]=Max(f[i],f[i-c]+w);
}
void Comple(int c,int w)       //完全背包
{
int i;
for(i=c;i<=m;i++)
f[i]=Max(f[i],f[i-c]+w);
}
void Multi(int c,int w,int num)     //多重背包
{
if(c*num>=m)
Comple(c,w);
else
{
int i=1;           //二进制思想,用一些数表示所有可能的组合。
while(i<num)
{
Zeroone(i*c,i*w);  //如num=13,可以用1,2,4,6表示所有组合
num-=i;
i*=2;
}
Zeroone(c*num,w*num);
}
}
int main()
{
int i,n;
int num[1005],cost[1005];
while(scanf("%d",&m)!=EOF)
{
memset(f,0,sizeof(f));
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d%d",&num[i],&cost[i]);
for(i=0;i<n;i++)
Multi(cost[i],cost[i],num[i]);
printf("%d\n",f[m]);
}
return 0;
}




                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: