您的位置:首页 > 其它

UVa644-Immediate Decodability-字符串-难度2

2013-12-23 14:45 344 查看
题目链接:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=585


  Immediate Decodability 
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that
no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:

A:01 B:10 C:0010 D:0000


but this one is not:

A:01 B:10 C:010 D:0000
 (Note that A is a prefix of C)

Input 

Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group
is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed
independently).

Output 

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not,
immediately decodable.

The Sample Input describes the examples above.

Sample Input 

01
10
0010
0000
9
01
10
010
0000
9


Sample Output 

Set 1 is immediately decodable
Set 2 is not immediately decodable


代码+思路

/*
* 主要是什么时候终止判断,flag的变换。
*/
#include<iostream>
#include<string>
#include<vector>
using namespace std;
string s;
vector<string> v;
int main()
{
#ifdef LOCAL
freopen("f:\\input.txt", "r", stdin);
//freopen("f:\\output.txt", "w", stdout);
#endif
int flag = 1, count = 1;
while(getline(cin, s))
{
if(s[0] == '9')
{
if(flag == 0)
cout << "Set " << count << " is not immediately decodable" <<endl;
else
cout << "Set " << count << " is immediately decodable" <<endl;
v.clear();
count++;
flag = 1;
continue;
}
else
{
if(flag == 1)
{
for(int i = 0; i != v.size(); i++)
{
flag = 0;
for(int j = 0; j != v[i].size() && j != s.size(); j++)
{
if(v[i][j] != s[j])
{
flag = 1;//flag == 1表示这个字符串不会重合了,跳出检查下一个
break;
}

}
if(flag == 0) break;//flag == 0表示有重合的了,后面不需要检查了
}
if(flag == 1) v.push_back(s);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: