您的位置:首页 > 其它

Lake Counting (POJ No.2386) DFS

2013-12-22 10:36 465 查看
Lake Counting

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 17082Accepted: 8654
Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure
out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.
Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output

* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output
3

Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

Source Code

Problem: 2386		
Memory: 496K		Time: 0MS
Language: C++		Result: Accepted
Source Code
#include <cstdio>
#include <cstring>
const int MAX = 105;
int n, m;
char field[MAX][MAX];

void dfs(int x, int y)
{
	field[x][y]='.';
	
	for(int dx=-1; dx <= 1; dx++){
		for(int dy=-1; dy <= 1; dy++){
			int nx = x+dx, ny = y+dy;
			if(nx>=0 && nx<n && ny>=0 && ny<m && field[nx][ny]=='W') dfs(nx, ny);            
		}
	}
	return ;
}

void Solve()
{
	int res=0;
	for(int i=0; i < n; i++){
		for(int j=0; j < m; j++){
			if(field[i][j]=='W'){
				dfs(i, j);
				res++;
			}
		}
	}
	printf("%d\n", res);
}

int main()
{
//	freopen("input.txt","r",stdin);
	while(scanf("%d%d", &n, &m)!=EOF){
		memset(field,'\0', sizeof(field));
		for(int i=0; i < n; i++)
			scanf("%s", field[i]);
		Solve();
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: