您的位置:首页 > 其它

poj 2255 Tree Recovery

2013-12-22 00:00 501 查看
摘要: 二叉树,已知前缀中缀,求后缀.

Tree Recovery

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10242 Accepted: 6437
Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

D

/ \

/   \

B     E

/ \     \

/   \     \

A     C     G

/

/

F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!

Input

The input will contain one or more test cases.

Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
Sample Input
DBACEGF ABCDEFG
BCAD CBAD
Sample Output
ACBFGED
CDAB
Source

Ulm Local 1997
[Submit] [Go Back] [Status] [Discuss]

/*=============================================================================
#     FileName: 2255.cpp
#         Desc: poj 2255
#       Author: zhuting
#        Email: cnjs.zhuting@gmail.com
#     HomePage: my.oschina.net/locusxt
#      Version: 0.0.1
#    CreatTime: 2013-12-22 18:18:29
#   LastChange: 2013-12-22 18:18:29
#      History:
=============================================================================*/
#include <cstdio>
#include <cstdlib>
#include <string>
#include <cstring>
#include <algorithm>
#define maxn 30

char pre[maxn], in[maxn];
char aft[maxn];
int len = 0;

void rebuild(int pc, int ic, int ac, int l)
{
if (l <= 0 || pc >= len) return;
char root = pre[pc];
aft[ac + l - 1] = root;

int rc_in = 0;
for (int i = 0 ; i < l; ++i)
{
if(in[ic + i] == root)
{
rc_in = i;
break;
}
}
rebuild(pc + 1, ic, ac, rc_in);
rebuild(pc + rc_in + 1, ic + rc_in + 1, ac + rc_in, l - rc_in - 1);
return;
}
int main()
{
while (scanf("%s%s", pre, in) != EOF)
{
len = strlen(pre);
rebuild(0, 0, 0, len);
for (int i = 0 ; i < len; ++i)
printf("%c", aft[i]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj