您的位置:首页 > 其它

Problem A.Ant on a Chessboard

2013-12-20 17:09 429 查看

ackground

  One day, an ant called Alice came to an M*M chessboard. She wanted to go around all the grids. So she began to walk along the chessboard according to this way: (you can assume that her speed is one grid per second)
  At the first second, Alice was standing at (1,1). Firstly she went up for a grid, then a grid to the right, a grid downward. After that, she went a grid to the right, then two grids upward, and then two grids to the left…in
a word, the path was like a snake.
  For example, her first 25 seconds went like this:
  ( the numbers in the grids stands for the time when she went into the grids)
 
25

24

23

22

21

10

11

12

13

20

9

8

7

14

19

2

3

6

15

18

1

4

5

16

17

5
4
3
2
1
 
1          2          3           4           5
At the 8th second , she was at (2,3), and at 20th second, she was at (5,4).
Your task is to decide where she was at a given time.
(you can assume that M is large enough)
 
 

Input

  Input file will contain several lines, and each line contains a number N(1<=N<=2*10^9), which stands for the time. The file will be ended with a line that contains a number 0.
 
 

Output

  For each input situation you should print a line with two numbers (x, y), the column and the row number, there must be only a space between them.
 
 

Sample Input

8
20
25
0
 
 

Sample Output

2 3
5 4
1 5

这道题我刚开始是看的是她的一个周期然后慢慢转但是超时了
#include<stdio.h>  

#include<math.h>  

int main(void)  

{  

    int n;  

    while(scanf("%d",&n)&&n)  

    {  

        int x=0,y=0;  

        int p=sqrt((double)n);  

        if(p*p==n&&p%2) {x=1;y=p;}  

        else if(p*p==n&&p%2==0){x=p;y=1;}  

        else if(p%2==0&&n!=p*p) {  

            if(n-p-1<=p*p){x=p+1;y=n-p*p;}  

            else{x=p-(n-1-p-p*p)+1;y=p+1;}  

        }  

        else if(p%2==1&&n!=p*p) {  

            if(n-p-1<=p*p){x=n-p*p;y=p+1;}  

            else{x=p+1;y=p-(n-1-p-p*p)+1;}  

        }  

        printf("%d %d\n",x,y);  

    }  

    return 0;  



后来上网查了查思路看看别人的代码有了思路就是把我的转的过程根据奇偶判断输入的数字在哪一行然后找临界点进行判断
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: