您的位置:首页 > 产品设计 > UI/UE

UVa694 - The Collatz Sequence-难度1

2013-12-19 20:41 190 查看
题目链接:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=635



  The Collatz Sequence 
An algorithm given by Lothar Collatz produces sequences of integers, and is described as follows:
Step 1:Choose an arbitrary positive integer A as the first item in the sequence.Step 2:If A = 1 then stop.Step 3:If A is even, then replace A by A / 2 and go to step 2.Step 4:If A is odd, then replace A by 3 * A + 1 and go to step 2.
It has been shown that this algorithm will always stop (in step 2) for initial values of A as large as 109, but some values of A encountered in the sequence may exceed the size of an integer on many computers. In this problem we
want to determine the length of the sequence that includes all values produced until either the algorithm stops (in step 2), or a value larger than some specified limit would be produced (in step 4).


Input 

The input for this problem consists of multiple test cases. For each case, the input contains a single line with two positive integers, the first giving the initial value
of A (for step 1) and the second giving L,
the limiting value for terms in the sequence. Neither of these, A or L,
is larger than 2,147,483,647 (the largest value that can be stored in a 32-bit signed integer). The initial value of A is
always less than L. A line that contains two negative integers follows
the last case.


Output 

For each input case display the case number (sequentially numbered starting with 1), a colon, the initial value for A,
the limiting value L, and the number of terms computed.


Sample Input 

3 100
34 100
75 250
27 2147483647
101 304
101 303
-1 -1



Sample Output 

Case 1: A = 3, limit = 100, number of terms = 8
Case 2: A = 34, limit = 100, number of terms = 14
Case 3: A = 75, limit = 250, number of terms = 3
Case 4: A = 27, limit = 2147483647, number of terms = 112
Case 5: A = 101, limit = 304, number of terms = 26
Case 6: A = 101, limit = 303, number of terms = 1


代码:

[cpp] view
plaincopy





/* 

 *注意点: 

 *   1)3*A+1 可能要大于int最大值,所以用long long int 

 *   2)如下 

 *     int n = 3; 

 *     long long int A = n; 

 *     则 n将不再是3 

 */  

#include <iostream>  

#include <string>  

#include <cstdio>  

#include <cctype>  

using namespace std;  

  

int main()  

{  

#ifdef LOCAL  

    freopen("f:\\input.txt", "r", stdin);  

#endif LOCAL  

      

    int times = 0, L;  

    long long int A;  

    while(cin >> A >> L)  

    {  

        if(A == -1 && L == -1) break;  

        ++times;  

        long long int  n = A;  

        int count = 0;  

        while(A > 1)  

        {  

            if(A % 2 == 0) A = A / 2;  

            else A = 3 * A + 1;  

            ++count;  

            if(A > L) break;  

        }  

        if(A == 1) ++count;  

        printf("Case %d: A = %lld, limit = %d, number of terms = %d\n",  

            times, n, L, count);//用lld输出 long long int  

    }  

    return 0;  

}  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: