您的位置:首页 > 其它

算法竞赛入门经典-前四章-UVa445 - Marvelous Mazes-非凡的迷宫-难度1

2013-12-18 20:21 585 查看
题目链接:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=386


 Marvelous Mazes 
Your mission, if you decide to accept it, is to create a maze drawing program. A maze will consist of the alphabetic characters A-Z, * (asterisk), and spaces.

Input and Output

Your program will get the information for the mazes from the input file. This file will contain lines of characters which your program must interpret to draw a maze. Each row of the maze will be described by a series
of numbers and characters, where the numbers before a character tell how many times that character will be used. If there are multiple digits in a number before a character, then the number of times to repeat the character is the sum of the digits before that
character.
The lowercase letter "b" will be used in the input file to represent spaces in the maze. The descriptions for different rows in the maze will be separated by an exclamation point (!) or by an end
of line.

Descriptions for different mazes will be separated by a blank line in both input and output. The input file will be terminated by an end of file.
There is no limit to the number of rows in a maze or the number of mazes in a file, though no row will contain more than 132 characters.
Happy mazing!

Sample Input

1T1b5T!1T2b1T1b2T!1T1b1T2b2T!1T3b1T1b1T!3T3b1T!1T3b1T1b1T!5T1*1T

11X21b1X
4X1b1X


Sample Output

T TTTTT
T  T TT
T T  TT
T   T T
TTT   T
T   T T
TTTTT*T

XX   X
XXXX X


代码:

/*
*1)Descriptions for different mazes will be separated by a blank line
*in both input and output.空行表示就是一个回车的行,没有空格。
*2)The descriptions for different rows in the maze will be separated
* by an exclamation point (!) or by an end of line.表示以'!'或者'\n'为
* 结束
*/
#include <iostream>
#include <string>
#include <cstdio>
#include <cctype>
using namespace std;

int main()
{
#ifdef LOCAL
freopen("f:\\input.txt", "r", stdin);
#endif LOCAL
char c;
int count = 0;//用来记总的字数
while(scanf("%c", &c) != EOF)//EOF end of file
{
if(isdigit(c))
{
count += c - '0';
}
else if(isupper(c) || c == '*')
{
while(count)
{
cout << c;
count--;
}
/*
*如果用:
*while(count--)
*{
* cout << c;
*}
*最后count为-1,所以还要把count置为0
*/
}
else if(c == 'b')
{
while(count)
{
cout << " ";
count--;
}
}
else if(c == '!' || c == '\n')
{
cout << endl;
count = 0;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: